Multiple Domain Use of Custom PHP

software development

#1

Alright. . . I had all of my problems fixed, but then I decided . . . Hey . . . let’s put this my office software in a subdomain instead for easier PDA Access. . . Well back to the drawing board on the PHP issues.

Okay, so I have moved all of my software over to the subdomain.

I followed the WIKI instructions on adding another domain to the custom php install:

[quote] * Go to the domain directory where you want to use the Custom PHP5 Compile (Example: /abc.com/)

  • Type: ln -s /home/USERNAME/DOMAIN_NAME/cgi-bin /home/USERNAME/SUB.DOMAIN_NAME/cgi-bin (Replace USERNAME with your actual username, Replace DOMAIN_NAME with your actual domain name where the custom php5.cgi in stored. Example abc.com. Replace SUB.DOMAIN_NAME with the actual sub domain you want to use for the custom php5)
  • Press Enter And You Are Done.
  • Upload the .htaccess with the AddHandler/Action methods as listed above to (Example: /abc.com/)
  • Upload the same .htaccess with the AddHandler/Action methods to the subdomain (Example: subdomain.abc.com) [/quote]
    I must really be doing something wrong here . . . I am Using PuTTy in SSH and when I execute the above -s {other stuff here} command I get “-bash: -S: command not found”.

Anyone have any ideas for me.


So bad at this I’m going CRAZY, with worry.


#2

Uhhh… are you entering ln -s or just -s ?

Cause that would make a rather large difference, heh.
ln -s is the proper method of doing it anyways.


Chips N Cheese - Custom PHP installs and the like!


#3

LOL . . .
Strike another person blunder . . .

I was only entering -s . . . much thanks . . . going to go try that now . . . I will let you know if it is resolved.

WELL . . . I am still getting the following:

I am in the main_ domain_where_customphp_is_working.com directory when I type this.


So bad at this I’m going CRAZY, with worry.


#4

the command is not In.

It is ln. l is for link. n is for normal. So use [color=#0000CC]ln -s[/color]

:stuck_out_tongue:

Save $97 with promo code: [color=#CC0000]97YES Sign Up NOW[/color]


#5

HeHe . . . I had just figured that out when I got this new post. . . that seems to have worked . . . However, now I am getting all kinds of errors . . .

I am not sure what is going on . . . Is the subdomain just suppose to get a symlink instead of its own cgi-bin. If so, then I am right there, but now I am getting strange errors (for example):

I am not getting this on the main domain, but I am on the sub.

Any clue . . . and by the way *** Thanks for all the help!


So bad at this I’m going CRAZY, with worry.


#6

as the message states, there is an extra , in your php.ini file. Check line 135 in your php.ini file, you should be able to spot the error.

Good luck

Save $97 with promo code: [color=#CC0000]97YES Sign Up NOW[/color]


#7

I removed it, and that did resolve that . . . however, it moves to the next one which is:

[quote]
Parse error: syntax error, unexpected T_STRING in /home/.hobbie/username/mountainmineralmanagement.com/cgi-bin/php.ini on line 135[/quote]

I don’t even know what that means . . .

Why would I be getting this on the subdomain and not the main domain . . . I am really trying to learn this, so understanding the issues as I fix them helps alot.

Thanks for the rapid response by the way.


So bad at this I’m going CRAZY, with worry.


#8

It looks like a missing “;”

You may not find the missing “;” in line 135. You may have a missing “;” before that.

Save $97 with promo code: [color=#CC0000]97YES Sign Up NOW[/color]


#9

This is now resolved completely . . . thanks for all the help.


So bad at this I’m going CRAZY, with worry.


#10

I’m glad that you solved the problem.

Would you mind to share how you solve the problem :stuck_out_tongue:

Save $97 with promo code: [color=#CC0000]97YES Sign Up NOW[/color]