MT-Yet another permissions problem

apps

#1

I’m having the same issue that a lot of people seem to have–“permission denied” and all of that. I’ve tried deleting the name of the dreamhost server (the one that changes around every now and then) from my local site path and local archive path, but it still won’t let me rebuild. I was posting fine two days ago.

When this happened before, I just changed the name of the dreamhost server in those two paths and I think it was fixed. Do I have to do that again? Any help is greatly appreciated.

Thanks,

Max


#2

Rather than just updating the name, delete it entirely. Here’s an excerpt from my MT install notes.

This is what you may see in the Configuration section:
/home/.directoryyoudonotrecognize/dreamhostusername/domainname.com/blog/

Delete the mysterious directory (it represents the name of a physical DreamHost server that may change in the future), so that the blog structure looks something like:
/home/dreamhostusername/domainname.com/blog/

Robert
http://www.wombatnation.com/


#3

Well I’m glad to see I’m not the only one having permission problems in MT all of a sudden. I am unable to rebuild any entries in MT. I can rebuild the templates, but not entries.

As far as I can tell this is a new issue. I added new entries to MT last Friday and didn’t have any problems. I tried to modify and add an entry Monday/Tuesday and that’s when the permission issues started.

At first the permissions issues were with rebuilidng anything on the site, now it is just with rebuilding entries. I have contacted DH support, but they only suggested that I need to change the permissions on the files in addition to changing the permissions on the folders. Although I have never set permissions on the files within MT (since they are created on the fly by MT) I set permissions on the files in addition to making sure the permissions were correct on the folders but still get permission errors.

Any help anyone could give on this issue would be appreciated.


#4

We’re not sure why this started happening all of the sudden, but if you’re having this problem it’s because your apache configuration doesn’t have a user for your scripts to run as in it.

Having us just re-configure your apache fixes it. I think there was some sort of one-time database hiccup that caused this problem to occur for any sites that had their apaches re-configed during the problem.

So please just write support, and be sure to mention what domain your mt.cgi script is actually running on (as that’s the one that needs to have its apache reconfigured).

josh!


#5

Thanks Josh. I’ll see if that helps.