MT permission errors



I’ve had MovableType successfully installed and running for many, many months. Until now I’ve not experienced any problems whatsoever making and editing posts. Suddenly, today, I’m experiencing “permission denied” errors when attempting to rebuild/publish/save files. This has never happened before. Apparently MT no longer has write access, though I did nothing to change the permissions to any of its directories myself. Any idea what could be going on here? None of the files in my MT site are PHP files, so that known permissions issue isn’t an issue. I’ve tried editing mt.cfg to remove the Temp files directive, I’ve tried forcing the UMASK settings, everything. Still, nothing-- I still get permissions errors.

What gives? Could DreamHost have changed the server environment somehow to cause these permissions errors?


Did you read through the following thread?

MT-Yet another permissions problem



Thanks, atacama, I didn’t until just now. Unfortunately your tips haven’t helped-- in particular I deleted the “hidden” DH directory in the local file path thinking that would do it. No dice. Still getting permissions errors. At this point I have no idea what’s going on-- the permissions on the files and directories haven’t changed, so DH Support is gonna have to help. Perhaps it’s an Apache user problem as alluded, but I’m not sure why this would just pop up unexpectedly after months of use without trouble.