Mt-load.cgi errors

apps

#1

his is the first time i’ve set up mt on my domain. when i ran mt-load.cgi i got:

Loading initial data into system…
Loading database schema…

An error occurred while loading data:

Table ‘mt_author’ already exists at mt-load.cgi line 55.

but then, i hit refresh and i got this error:

An error occurred while loading data:

Connection error: Can’t connect to MySQL server on ‘mysql.semidigital.com’ (111)

so i’m still getting these errors every time i refresh, but never together. any suggestions? i’ve got to get this up asap for a student project!!

thanks!


#2

First check to see if the database and the table already exist.

  1. Go to the MySQL section of the DreamHost control panel
  2. Click on the domain name for your database (e.g., mysql.semidigital.com)
  3. Login with the database username that you used in mt.cfg and the password you used in mt-db-pass.cgi

This will log you into PHPMyAdmin. Look in the leftmost column of the page to see if the table already exists.

If you run mt-load.cgi multiple times, you will get errors about the tables already existing. It doesn’t overwrite them, at least not in my experience of accidentally rerunning it. As far as the connection error messages, I probably can’t help you. The only times I have seen this have been when I tried to use the database before it was active (normally takes less than an hour, sometimes much less) or long ago when there was a problem that Support needed to fix.

Robert
http://www.wombatnation.com/


#3

when i go to goodies > mysql then click on mysql.mydomain.com, it just takes me to the actual url. i don’t get any kind of login?

the database was activated months ago. but it seems to be acting like it really isn’t activated.


#4

so i have discovered that i accidentally made mysql.semidigital.com a subdomain. however, i have deleted that and everything “should” be working properly. however i’m still getting this error:

Got an error: Connection error: Can’t connect to MySQL server on ‘mysql.semidigital.com’ (111)

so, i emailed the support staff at dreamhost, and they said that everything should be working fine because the database can be connected to:

schnapps: 12:00pm# mysql -h mysql.semidigital.com -u miamtadmin -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 533076 to server version: 4.0.18-log

soooo. now what? and still, when i go to mysql.semidigital.com in a browser, i don’t see the web interface that supposidly should be there.


#5

also, he checked to make sure tables did exist:

mysql> show tables;
±------------------+
| Tables_in_miamtdb |
±------------------+
| mt_author |
| mt_blog |
| mt_category |
| mt_comment |
| mt_entry |
| mt_ipbanlist |
| mt_log |
| mt_notification |
| mt_permission |
| mt_placement |
| mt_plugindata |
| mt_tbping |
| mt_template |
| mt_templatemap |
| mt_trackback |
±------------------+
15 rows in set (0.00 sec)


#6

What happens when you try to login to MT? I accessed mt.cgi on your site and got the login screen, but I didn’t try to login out of respect to it being your site, not mine. Can you login with the default username and password?

Robert
http://www.wombatnation.com/