MT 2.661: Your DataSource directory ('./db')

apps

#1

I am installing MT 2.661 and I am running into an error when I try to run mt.cgi I get the following error:

Got an error: Your DataSource directory (’./db’) does not exist.

I read in the mt forums about this error when not running Berkeley DB that in the mt.cfg file at line 26 the the DataSource should be commented out

The filesystem path to the ‘db’ directory, where your MT database

files are stored. You will probably need to change this when you

first install MT; instructions for doing so are in the Installation

Instructions, in INSTALLING THE MOVABLE TYPE APPLICATION CODE, Step 8.

DataSource ./db

http://www.movabletype.org/support/index.php?act=ST&f=7&t=37278&hl=datasource+directory&s=12daf5dcefde7f6a877abe9154d9caa8

however even when I do this, I still get the same error when I try to run mt.cgi in my browser. What they hey? I have set the following to point to the correct data per the wombat dreamhost directions so it should be looking for MySQL. But what I don’t understand is why I am still getting the error when I have commented line 26 out.

Ideas?!


#2

I took a look at my own blog’s mt.cfg file, and I don’t even have that line commented out.

Perhaps you don’t have the MySQL settings set correctly in mt.cfg, so MT is assuming you want to use Berkeley DB. I’m also guessing that if it doesn’t find the DataSource setting in mt.cfg, it attempts to use the default value of ./db. This is just a guess; I haven’t looked at the actual code.

You’ve probably already done this, but check again to make sure the following settings are correct for your installation.

Settings for MySQL

ObjectDriver DBI::mysql
Database Name of your database
DBUser Valid username for your database
DBHost domain associated with your database

The first setting is crucial. Capitalization matters.

Then, go to the MySQL section of the control panel.

Find the database you created for MT. Make sure the database name exactly matches the value above in mt.cfg for Database.

Directly below the name of your database should be a table (an HTML one) where the first column is titled “Service Type”. There should be at least one row with an icon meant to represent a user. The value under the “Setting” column is the name of the user. Make sure this name exactly matches what you have entered for DBUser.

There should also be a row with an icon meant to represent a server. The setting is the domain name associated with your database. Make sure the value exactly matches what you have entered for the DBHost setting.

Robert
http://www.wombatnation.com/