Moving WP site from to


I seriously need some help. We are launching an online magazine.

We set up a placeholder wordpress install at ( that had some basic information about the upcoming magazine. is fully hosted with dreamhost.

We’ve been developing the site on a new wordpress install at The first issue is finished and we are ready to launch, and I thought I could just redirect to so when people typed in or followed a link to they would be redirected to the live issue at

I used the redirect function in the panel on another domain I wasn’t using to see if it would work and I get and infinite redirect loop.

How do I fix this. Please help!


add to your .htaccess

Redirect 301 /index.php

That should work if I am not mistaken


Do I do this in the Dreamhost panel?


FTP to your WP folder and you will see the .htaccess, download it or modify it online.
If you do not have a FTP program, download Filezilla for free of the internet.
Note: to FTP access your WP you must have it installed as custom, with easy install you will not have FTP access.[hr]
Of course you can also use the WebFTP or FTP option in the Panel under Manage Domains


I think I installed WP as custom. I’ve been FTP’ing in which is how I’ve been adding some files, themes and plugins.

But I don’t see a .htaccess file anywhere. Is it automatically created? Is it hidden. Could there not be one and I need to create it?

Thanks ronthai for trying to help, but I’m still a little confused. thoughts?


It is in your main folder so depending on what FTP program you use you may have to give the command or setting to show invisible files like .htaccess.

If you use the WebFTP (in the panel under Manage Domains) option it will show up[hr]
List of FTP programs on how to show hidden files[hr]
an other one


hmm. I made invisible files visible so now I see .alias .bash_profile .bashrc and .cshrc, but not .htaccess

Is it possible that it isn’t there? can I create it? what needs to go in it besides the snippet you gave me earlier to solve my current problem.

there was a problem with the server about a couple of days ago and they had to reboot/restore the server. Could the .htaccess not have been restored?:

[quote]The server
your sites are hosted on (randall) became unresponsive and had to be
rebooted shortly after you wrote in. It’s now back up and running
normally as are your sites. The admins will be keeping an eye on the
server for a bit longer just to make sure it remains stable.[/quote]

So I just created a .htaccess file in folder and then added the line [quote]Redirect 301 /index.php[/quote] as you suggested. It looks like its working. Thanks!

But what else should be in that .htaccess file? It seems weird that the file wasn’t there.



Plugins or some settings (permalinks) in WP create the .htaccess, but if you had nothing that needed it yet not worry about it, since now you have created one. Any automated additions needed for .htaccess the plugins and WP will do themselves without deleting your current edit.[hr]
and yes the redirect indeed works now[hr]
Just hope you are not going to install new WP for every new issue are you?


Thanks so much for your help!! I really appreciate it.


An easier way for inexperienced users might be to put an index.php at the root, containing something like this

<?php header("location: /issue01"); ?>

But hey, are you gonna do a separate WP installation for each issue? That will give you many headaches in the future!