Moving WP from domainA to domainB

wordpress

#1

Hi,

I created my WP site at bethcordi.com/soakupthefun, but now that it’s nearly complete, I would like to move it to it’s official location, which is soakupthefun.com. Both domains are with DH, but soakupthefun.com is currently redirecting to another site.

I’ve searched and searched, but I can’t seem to find clear, succinct, and most importantly plain english instructions for doing this. Can someone point me in the right direction?

Thanks so much!

Beth


#2

Anyone? Please. :slight_smile:


#3

Hi Beth,

Here’s the easiest route that I’d take and suggest:

Step 1) On your Manage Domains page in the panel, click “Edit” next to soakupthefun.com and make it Fully Hosted rather than a redirect. In the Fully Hosted settings, make sure to host it on the same user bethcordi.com is on.

Step 2) To minimize downtime, I’d wait until you can access soakupthefun.com as a fully hosted site (in case DNS propagation takes a little time at this point) before step 2. Once you can reach soakupthefun.com and see the “Coming soon!” page we put there by default, log into your WP dashboard at bethcordi.com/soakupthefun/wp-admin. Go to your general settings there, and change the URLs to be http://soakupthefun.com rather than bethcordi.com/soakupthefun.

Step 3) Connect to the server with your FTP user (or via SSH) with an FTP client. Drag the sub-dir bethcordi.com/soakupthefun back out/up two levels to your user directory. Once there, you can either move all the contents from it easily into your new soakupthefun.com directory there, or better, just delete the new/blank soakupthefun.com dir and rename your /soakupthefun dir to soakupthefun.com. Alternatively, you could just copy all the files in bethcordi.com/soakupthefun/ and paste them in the existing soakupthefun.com directory. Whichever route you prefer, you should end up with all your WP files in the soakupthefun.com dir there.

That should be all that’s needed. In some cases, if you’re using a heavily customized theme that has your URLs hard-coded in any places, you’ll have to go through and manually update those links to use the new URL.

Additional info on moves and troubleshooting can be found here as well: http://codex.wordpress.org/Moving_WordPress

I hope that helps! :slight_smile:


#4

Thanks Ellie. It worked! :slight_smile:


#5

I’m going to piggyback on this thread if that’s ok!

I used the above method posted by DH_Elle S to move my blog but am now running into some issues. On my permalinks page it displays this:

[i]If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

RewriteEngine On RewriteBase / RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] [/i]

I’ve changed the user permission for my .htaccess file and added the code but with no luck; the error still appears. Also, if I click on any of my website links from within the Wordpress dashboard (such as Preview for posts, etc.), I get a white page of death. I can type the link into the address bar and it works, but clicking on it from within the dashboard does not. The only other problem I’ve noticed so far is that my pagination is not working. When I click on “next” or any of the page numbers, I get a “This page cannot be displayed” error from the browser. Have tried it with both IE and Firefox and on at least 3 different computers.

Please help! Was so happy to find this much easier way to transfer my blog but it’s really going to be disappointing if I can’t figure out how to fix these issues.

Blog in question is twilightsleep [DOT] net

Thanks in advance!


#6

It seems like you might’ve figured things out since yesterday, as it seems like all the pages on your site are working and I can’t find any errors. From the sounds of it, you may have had a plugin or custom theme settings still trying to use the old URL. These would be corrected at the individual settings pages for your theme and any plugins that have their own settings. I’m not sure about your paginate not working (as it works now too), but I assume it was a setting issue as well. I don’t see that you have that plugin installed now, but a re-install of that should do the trick in any case. :slight_smile:

Your .htaccess file also looks fine now from here, but if you’re ever in doubt in the future again, you can actually just delete the .htaccess completely and then re-save your permalink settings from the WordPress dashboard; It will generate the correct new .htaccess for you. :slight_smile:


#7

I did figure it out - sorry, I forgot to post here! Actually what happened was under the General settings where you put in your Wordpress address (URL) and your Site address (URL), my WP address was correct but my Site address was missing one “t”! A friend caught it and once I changed that, every single error I was having went away, haha.

So thank you for an, in fact, extremely easy alternative moving a blog from one domain to another!


#8

D’oh! Haha :stuck_out_tongue: No worries! If you run into any trouble again, just let us know here, on Twitter @dreamhostcare, or submit a ticket to our support team. We’ll be happy to help you out anytime. :slight_smile:


#9

Ok, I’m back - it seems ALL my issues weren’t fixed the other day. :frowning: I noticed today that when I upload new images, they still retain the link of my old domain instead of the new one. For example:

instead of

Any ideas on what might be causing this or how I can fix it?


#10

Hi shananigan,

There were a couple of odd problems. First, your WPCACHEHOME definition in wp-config.php was still pointing to your old home directory, and wp-super-cache was marked as being active in the database, while it wasn’t installed. I fixed that by copying the wp-super-cache files to your plugins folder.

Then I looked in your database and found a value for “ossdl_off_cdn_url” which is set to your old URL. I think that’s from http://wordpress.org/plugins/ossdl-cdn-off-linker/ but I don’t know it off the top of my head. I would guess that plugin is the cause though.


#11

Hmm…I’ve never downloaded that plugin though? I don’t even know what it does. Is there any way to fix it?


#12

Hi shananigan!

I had my support lead take a look into this for you, and here’s what happened:

Checking into your database, he noticed that “upload_url_path” was row 67 in your _options table there, and there were a few other random values that still had the old URL.

He then used a sql query like this one to replace what it could find in your post content.

We recommend that you delete any inactive plugins, and any active ones that have settings; Just double-check and make sure they have the new URL saved there if applicable.

You should be good to go. :slight_smile: If you’re not, let me know!