Moved joomla, sites broke, what did i do wrong?


#1

hello folks, i moved my joomla site to a new domain but now it dose not work. any ideas as to what i did wrong? steps

  1. i backd up the mysql db
  2. i made a new mysql host on the new domain, just to be on the safe side.
  3. i uploaded a copy of the db to the new host.
  4. i issued cp -r oldsite.com/* newsite.com
  5. i edited configureation.php as follows.

i changed

var $log_path = ‘/home/.livingston/username/old.site.com/logs’;
var $tmp_path = ‘/home/.livingston/username/old.site.com/tmp’;

to

var $log_path = ‘/home/newsite.com/logs’;
var $tmp_path = ‘/home/newsite.com/tmp’;

i allso updated the mysql and email entrys accordingly. now the main page loads fine, but when you try to access any other page you get.

Not Found

The requested URL /component/content/article/31-general/65-screen-quotes-7 was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

any idea’s?


#2

Well, it could be a couple of things, but first things first:

  1. What version of Joomla! are you using?

  2. It looks like you have confused an address (or url) for a path - on DreamHost:

var $log_path = ‘/home/newsite.com/logs’;
var $tmp_path = ‘/home/newsite.com/tmp’;

is not going to work (that is not a path to anything on DreamHost). It should look something like this:

var $log_path = ‘/home/yourusername/newsite.com/logs’;
var $tmp_path = ‘/home/yourusername/newsite.com/tmp’;

  1. Make sure you clear your cache!

  2. Make sure you have modified your “live_site” variable (depending upon your Joomla! version, you can do that in the admin or in the configuration file). I suspect this is a likely cause of your “not founds”

  3. Finally, your urls indicate you are using SEO urls of some kind (built-in to Joomla! or from a compopnent), and you will need to get that sorted (make sure the component is properly installed and configured if there is one involved, and/or make sure your .htaccess file is correct for your new home!).

–rlparker


#3

joomla version 1.5

i changed the two entrys to

var $log_path = ‘/home/username/newsite.com/logs’;
var $tmp_path = ‘/home/username/newsite.com/tmp’;

i cant find a live_site entry in the configuration.php file. i can access the admin back end but i dont see it there either. ive got to be missing something.


#4

Yeah … I was afraid of that … they moved stuff around a bit in 1.5, and I haven’t taken the time yet to sort through where all the changes are.

What is your domain/url?

–rlparker-


#5

Ok … try this:

Look in configuration.pgp for the line:

var $live_site = ‘’;

… and set it to:

var $live_site = ‘http://yoursite.tld’;

or whatever the full url to your Joomla! installation is.

–rlparker


#6

dont see a configuration.pgp and there is no live site variable in configuration.php… however i did a test i turnd of SEF and cleard my cache, and it worked. i re-enabled sef, cleard my cache and back to not working. is there another configuration file some where? im at a loss. all the googling ive done says ive done everything right, maybe theres a problem with my htaccess file?

oook. odd, there is no htaccess file showing in ftp. allso in ssh ls -al shows no htaccess file. weird.


#7

ok i did…

cp oldsite.com/.htaccess newsite.com

and guess what? its working. i wonder why it didnt copy htaccess over in the first place? allso makes me wonder what else didnt get copied over.


#8

Yeah, I’m sorry about that! It was my typo - I was talking about configuration.php.

If there is no “live_site” variable there, you can add one, but you might not need to from what you have described in this last post.

Ok, now we are getting somewhere. Don’t forget that there are two (at least!) caches involved - the cache in Joomla! and your browser’s cache! This is one of the reasons I asked for the url to your site - my browser will not have any cached data for your site. :wink:

I think your problem may still be cache related from what you have described.

  1. Log into the Joomla! back end, and disable the Joomla! cache and sef urls

  2. log out

  3. clear your browser’s cache (depending upon your browser, you may even need to close it and restart it after “clearing your cash” to completely clear it).

  4. Hope that your ISP, router, OS is not caching anything.

  5. Restart your browser and test your site.

If this works then Joomla is essentially working correctly.

If you now want SEF urls, repeat the above process completely, except turn on SEF in step 1. and add this step between steps 4 and 5: -> 4.5) rename htaccess.txt to .htaccess

If it is not working now, and you are completely sure your caches are cleared (I always try clearing it twice and restarting the browser as I have found some browsers caches to be very “sticky”), then the problem is likely to be in your .htaccess file or that “live_site” var we talked about.

You won’t need that .htaccess file unless you use SEF urls, but you will need it if you do! It might not be showing in your FTP client if you do not have it configured to show hidden files, but it should show up in ssh with ls -al. Note that for the SEF urls to work, you are looking for “.htaccess” (note the “dot”).

Joomla! ships with no “.htaccess” file - the file is called htaccess.txt, and you have to rename it manually if you enable SEF urls! If you have a file named “htaccess.txt”, but none named “.htaccess”, then that is most certainly the cause of your trouble.

If Joomla! back end has SEF URLs set on, rename htaccess.txt ro .htaccess.

If Joomla! back end has SEF URLS set OFF, rename .htaccess.txt to something else (htaccess.txt, orig_htaccess, whatever)

–rlparker


#9

Ha! Well, good deal! If something else didn’t get copied, you’ll know soon enough because stuff will start breaking pretty dramatically! :wink:

What I’m wondering is why you just didn’t rename the oldsite.com directory to newsite.com instead of cp ing everything?

–rlparker


#10

:What I’m wondering is why you just didn’t rename the oldsite.com directory to newsite.com instead of cp ing everything?"

you mean i could have done that? are you serious? oy, well i just learnd something new… i guess i could have renamed oldsite.com to newsite.com then remade oldsite.com with the redirect in htaccess… go figure :expressionless: well thanks for all the help, i would have givin up a LONG time ago if it wasnt for your assitance.


#11

Yep! I learn something new every day!

Well, that’s the general idea, though you still would need to correct those php variables in the configuration file so they reflect the new url.

At any rate, I’m really glad you got it running again, and I’m happy to help when I can. :slight_smile:

–rlparker


#12

I think I am right…

cp -r olddir/* newdir
will not copy hidden files ( starting with leading "."
mv would have been the best bet…
cp would have to be done in two stages…

cp -r olddir/* newdir
and
cp -r olddir/.* newdir

So if you did miss any other files they will be dot files… ( hidden files )

That is providing I am right… hehe…


Dave Blakemore


#13

I think you are correct. :wink:

http://www.linuxquestions.org/questions/linux-software-2/can-i-cp-hidden-files-627605/
http://www.webmasterworld.com/forum40/1741.htm

–rlparker