Moveable Type problems - unknown MySQL Host Server



When trying to load mt-load.cgi I get the following message;

“Loading initial data into system…
An error occurred while loading data:
Connection error: Unknown MySQL Server Host ‘’ (2)”

I have set up the host in the Dreamhost Panel almost 2 days ago and it still is not recognising it. The Panel says it is active and I can access the phpMyAdmin interface using my username and password.

I have loaded the files in ASCII and I have changed permissions on .cgi files to 755.

Also, the Moveable Type installation on another domain which was previously working now appears to be corrupted since I have installed a new database and hostname. I can’t get it to accept my old username and password. I can’t get it to accept Melody/Nelson. I can’t get it to accept any username / password configuration I have ever used. I have deleted all cookies and I have even tried to re-run mt-load.cgi which gets an internal server error (500) message.

I have already spent so long trying to make this work. I have read the instructions a zillion times and can barely see them anymore. I have experimented all I know how or can guess with the databases, and I have read all the forums I can find and tried all of thier suggestions and I still can’t get either database to work. I am going utterly bonkas. Can anyone help - please??


This domain doesn’t appear to be registered, and our servers aren’t configured for it either. Are you sure that’s the right domain?


Bah! You know what is was? I had misspelled my domain name in the sql line of mt.cfg. I just knew it would be something little and simple that I had overlooked and just couldn’t see. Hence my double checking a squillion little things, but I missed that one. That’s what happens when I get flustered…

Thanks for your help Will :slight_smile:

Now I just have to figure out why my confirmation pages are missing and what the deal is with the password problem on the other domain. Gee whiz this is fun! But I am relieved that the missing domain problem is resolved…