MovableType - permission error when posting

apps

#1

I set up MT many months ago, but used only two or three times. Today I tried to post a new entry, but when I try to save it, MT comes up with this:

mkdir /home/.cabbie/tranglos: Permission denied at lib/MT/FileMgr/Local.pm line 104

Line 104 is this:
File::Path::mkpath([$path], 0, 0777);

I can see what it does and I can imagine why it might fail, but I don’t know enough to fix it - I don’t know what should be fixed, since it worked fine initially. Looks like something outside of my MT installation must have changed.

Thanks in advance for any hints.
.marek


“Well I can get the ‘a’. But how do I put the circle around it?”


#2

Euros to beignets, your problem is that you have incorrect values for your LocalSitePath and/or your LocalArchivePath. So how did that happen all by itself? The problem is the .cabbie in the path. Your files were probably moved to a different server since the last time you posted. Will can it explain it far better than me.

Go into the MT admin interface (mt.cgi), click the “Manage Weblog” link under your blog, then click the Weblog Config button in the left menu column. In the edit boxes for LocalSitePath and LocalArchivePath, delete the mysterious directory that begins with a “.” that is in the middle of the paths.

Robert
http://www.wombatnation.com/


#3

Worked like a charm. Thank you!
.marek


“Well I can get the ‘a’. But how do I put the circle around it?”