MovableType 3.1.7 probs due to no CGI-BIN directory

apps

#1

Hey,

I just signed on with DreamHost and I’m trying to setup MovableType. I’ve successfully installed it on several servers at work, both OS X Server 10.3 and RedHat 7.3 with no problems.

Now when I try to install it at DreamHost, the install gets screwed up because there is no CGI-BIN directory outside of the publicly accessible root web directory. And it seems DH is running CGIwrap for extra security.

How do you install MovableType in this environment?

  1. I tried creating a CGI-BIN in the root web directory and installing MT there, but the DB abd all the CGI are exposed.

  2. I then tried creating a PUBLIC-HTML directory in the domain folder and tried change that to the root web directory. Didn’t work.

  3. Should I not worry about secure directories at all and NOT follow the MT install instructions and put everything into a single _movabletype directory and run everythign from there? Is that secure?

Any help would be appreciated…

ernie


#2

This famous Installing Movable Type at DreamHost guide, written by a fellow DreamHost customer, may be of help to you.
All the best -
marsbar


#3

Also, you really should use a mysql database - not berkley as it sounds like you were talking about that.

and CGI wrap will only effect MT if you enable it in the mt.cfg file.

-Matttail


#4

I’m going to second that link! It got me through my MT installation with only a minimal amount of screaming/hair pulling/etc!

Definitely go MySQL. Also, you don’t need a cgi-bin here at Dreamhost.

Good luck!

Jalpuna! - personal blog
this is the box - radio blog
robsdemo - what I do