Movable type

apps

#1

Hello.

I followed the instructions to a T on the wombat nation directions.

all was going well, but when i goto mt.cgi in my webbrowser, it gives me a 403. and says additionally, a 404 was not found.

i have checked permissions on all files/directories as far as i can tell. i have initialized. i have done everything i can think of.

any help??


#2

A 403 error means you tried to access a page that you don’t have access to retrieve through a web browser. Is there any chance you have a .htaccess file in that directory with a setting that is preventing you from accessing that page?

A lot of times you see a 403 error when you try to get a directory listing for a directory in which Indexes have been disabled. Maybe you have

Options -Indexes

in the .htaccess file in a directory for which you don’t have an index.html (or index.php or index.htm) file? That seems unlikely, though, since you say you are trying to access mt.cgi, and not a directory listing.

I think that the 404 error you saw just means that you don’t have a custom “Page Not Found” ErrorDocument page, so the Apache web server just sends back a generic error page. You can specify a custom error page in a .htaccess file.

Robert
http://www.wombatnation.com/


#3

apparently it did have something to do with the htaccess file. i renamed it and was able to enter.

but that was part of the directions on the wombat nation dreamhost movable type instructions. to create a htaccess file with the deny all from getting files text.

oh well, works now…

thanks


#4

My fault on this one.

In that bit of protection code in the htaccess file, i put in the file to be protected as mt.cgi. it should have been mt.cfg

so close…