Movable type

apps

#1

I’m trying to set up my movable type blog but am having trouble with mt-load.cgi. I get a connection error:

Connection error: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

I really have no idea abuot sockets, and havent seen access to a directory even remotely like this. I’ve seen soem posts abuot this elsewhere, but nothing too helpful. My mt-db-pass has my password, and my logon and domain info are correct.


#2

That’s based on connecting to a MySQL server on the local machine. You’ll need to edit the Movable Type config and set it to use mysql.[your domain] or whatever MySQL hostname you setup in the web panel, authenticating with the username / password you created. I think there are a couple of “movable type on DreamHost” howtos that might have more specific instructions - try google and the kbase.


#3

i added the DBHost line to the mt.cfg so its points to my mysql.domain.com, but i still get teh same error. Its still trying to look locally, and i have no idea how to tell it not to.


#4

Compare what you entered in mt.cfg to the info in my MT install notes.

Robert
http://www.wombatnation.com/


#5

unless i missed soemthign fairly obvious which ive looked over a bunch already, i don thtink so. DId anything change from version 2.5 to 2.661?


#6

There were no changes I know of that would affect those install instructions. I’ve used them successfully with MT 2.65 and 2.661 (after adjusting the filenames for 2.661, of course).

Robert
http://www.wombatnation.com/


#7

I really dont know what to try anymore. THe only thing i did differently is that i downloaded teh zip, and not the tar.gz. I unzipped it on my local drive, and then upload the folders separately in ascii except for the images. ALl the permissions on teh folders are 755, and the cgi scripts too. I keep getting:
Connection error: Access denied for user: ‘dbAdminPJ@pogo.dreamhost.com’ (Using password: YES)

If I delete teh mt-db-pass.cgi it says NO instead. Have you seen this error before?


#8

No, I’m afraid I haven’t. Have you searched Google and the Movable Type support forums, perhaps searching on some or all of the text “Connection error: Access denied for user:”? Sorry I couldn’t be of more help.

Robert
http://www.wombatnation.com/


#9

I found a setting on dream host to run mysql as PHP. It mentions that some third party programs like gallery only run if this in enabled. What does this actually do? Is this required to run movable type as well?


#10

I’m not sure what it would mean to run MySQL as PHP. I’m pretty sure MySQL is written in C or C++. It is definitely not written using PHP. However, the default MySQL admin tool that DreamHost supports is written in PHP.

Movable Type is written in Perl, not PHP. If you are running on a DreamHost shared server, MT does need to be run as CGI, as opposed to via mod_perl. That will happen as part of the default setup on DreamHost.

Running PHP or Perl programs as CGI does put limits on what they can do, but it won’t affect the functionality of Gallery or MT. The good thing for DreamHost and for the other people on your shared server is that running them as CGI significantly limits the damage that a bug or poor design in one of the programs could cause.

Robert
http://www.wombatnation.com/