Movable Type upgrade ends in error 500

apps

#1

I tried upgrading my blog from Movable Type version 3.2 to 4.1 and my upgrade script keeps giving me the oh so dreaded 500 Internal Server Error. I’ve checked my domain’s error log and I’m getting the following lines each time I’m running the upgrade script:

Out of memory!
Out of memory!
Out of memory!
[Wed Apr 2 01:02:11 2008] [error] [client 89.36..] Premature end of script headers: /home/user/domain.com/cgi-bin/mt-upgrade.cgi
[Wed Apr 2 01:02:12 2008] [error] [client 89.36..] File does not exist: /home/user/domain.com/internal_error.html

(I edited some sensible lines.)

So it looks like the upgrade script is running out of memory. Is there anything I can do? Because DreamHost has been really helpful, not. I’ve submitted a support ticket with the issue more than 22 hours ago and I haven’t received any answer yet. And during all this time my blog is inaccessible…


#2

I’ve managed upgrading by following these instructions:
http://www.movabletype.org/documentation/upgrade/upgrading-a-really-large-database.html
However, I still can’t log into the admin interface. Same “Out of memory!” error.


#3

Issue seems completely solved. By your’s truly…

Tip: Backup and then delete your old plugins before upgrading. You can re-apply them later one-by-one.


#4

Im trying to install movable type 4.1 on my dreamhost account and keep getting an internal error 500. I followed all the instructions on the wiki, but not even the mt-check.cgi is working. help please.


#5

If you are getting Internal Server Error 500 on even mt-check.cgi, it is likely that one, or more, of the most common causes of that on DreamHost is involved:

  1. Make sure all your .cgi files are transferred using ASCII mode of FTP

  2. Make sure all your .cgi files are set to 755 permissions (even if instructions say 777 or 775)

  3. If you have edited your files with a windows or MAC OS9x editor, make sure that you account for the different line endings in use, which any one of the following methods will accomplish:

a) Save the file with *nix line endings if your editor allows it
b) Open and re-save the file on the server using a *nix editor
c) use a utility on your computer or the in the shell to do the conversion. (dos2unix, fromdos, etc)

It also might help to inspect your error log to see what additional information is provided about the error.

–rlparker