Movable Type trouble on subdomain


#1

Hi guys. first of all, I don’t speak english in a ‘good way’.
Well. I have MT installed on my domain vidarara.org, but I made a subdomain for a friend (barnert.vidarara.org) first I made it with a system user, but when I wanted to write files from my user (jpincheira) on his barnert.vidarara.org directory under his account (/home/barnert) I got permissions errors. So I did the obvious step, deleted his system user account and I just added his subdomain (barnert.vidarara.org) to my system user account (jpincheira) and MT could write its files on the folder I redirected his domain (to an account under my user, where MT installed and it can write because there aren’t permission troubles). Now my problem is that when you create subdomains under a user account that already have other domain working (in my case my user is jpincheira and I have running the ‘vidarara.org’ domain) on the subdomain you add you can’t run cgi, so when I try to comment on my friend’s blog I get a typical cgi execution error: “No entry_id”. So, how can I enable that subdomain to get cgi working?

P.S.: it’s fully hosted.

Thanks guys! I hope you reply this :slight_smile:

And again sorry for my poor english.


#2

Hi, I’m almost lost and don’t know which user is controlling which domain. :stuck_out_tongue:

I think DH disable CGI by default for new subdomains. You can enable it through DH panel --> Domains --> Manage Domains --> Edit Web Hosting. Enable FastCGI Support

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#3

Me too, I read through the post a couple of times and I’m still not sure who owns what :slight_smile:

No, this is not correct. As far as I am aware, CGI is enabled for all new domains and sub-domains. FastCGI is disabled by default, but this is just a more efficient form of CGI, enabling or disabling FastCGI does not enable/disable basic CGI support.

jpincheira,

Have you checked the permissions on the directory you are using for the sub-domain?

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#4

Well. The user who is admin the domain barnert.vidarara.org is jpincheira which admins vidarara.org by default too. (sorry about not explaining it well before, guys).
And when you try to comment here is where I get the error.
http://barnert.vidarara.org/2007/01/credito_universitario.html#comments

I tried to correct the the directory where the subdomint is pointed to: chmod -R 777 barnert.vidarara.org/ (under /home/jpincheira, bause jpincheira is the user who admins/owns this).

Hope you can help me on this, thanks guys!


#5

I’m not an expert at such things, but I think 755 would probably be safer.

If I understand you correctly, you have the domain and sub-domain both under the control of your machine user and the web directories for both are within your home directory. You have MT installed in both web directories and it works fine in your main domain, but not in the sub-domain.

While I have very little experience with MT, this seems strange to me, as here at DreamHost sub-domains are basically treated the same as full domains, if your MT install works fine in your main domain, a similar install should also work in your sub-domain, assuming the (sub)domains are configured the same (PHP versions etc.).

When you changed the user that controls the sub-domain, did you re-install MT in the sub-domain, or did you copy the existing install from the old users home directory to your home directory?

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#6

Hi dude. Well. Let me explain it to you. I have one installation of movable type. and in my home I have this:

[tejava]$ ls /home/jpincheira
Maildir backup barnert.vidarara.org logs vidarara.org
[tejava]$

I have MT installed on vidarara.org/mt/ and I have configure MT to have 2 blogs and it write its static files on barnert.vidarara.org and vidarara.org/blog/ directories under my home.

I have that comment issue in both of the directories/domains (because they have the same name).

I found this on the internet: http://www.reilly2001.info/whim/archives/movable_type/mt_error_fixed_how_awful_no_comments_2003-08-12.html where the guy explain that is an error because of the CGIPath configuration on the mt-config file. He says it needs to have the www. in that line of the MT conf file. But I already had that line in that way.

The problem was I had both of my 2 domains configure to not have www.
The Config panel:
How do you like the www in your URL?
Both http://www.domain.com/ and http://domain.com/ work.
Add “www.” if somebody goes to http://domain.com/
Remove “www.” if somebody goes to http://www.domain.com/

I had Remove “www.” to get movable comments working. But now I changed it to “both www. and without www” and it works. Well that disgusts me a bit because I don’t like to use pages with www. You can read more of this here http://no-www.org/

Thanks guys for your help. Now it’s fairly working. :slight_smile:


#7

Arh, now I understand, one installation creating both blogs. Sorry for the confusion, but I assumed (wrongly) that you had two installations.

Well we really didn’t help much :slight_smile: , but thanks for coming back and posting the solution, it might be of use to someone in the future suffering the same problem.

Good luck.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)