Movable Type locked me out

apps

#1

Every time I try to log into my Movable Type installation, I get “Invalid Logon.” This has happened to me before, and it was a Dreamhost change. I don’t remember how I fixed it.

I’m guessing that a database setting or something changed on Dreamhost because I have two other MT installations hosted with other hosts, and they are both just fine.

I have tried reloading Spec.pm and the Spec folder into extlib. That did nothing. I am not that technical and am at a loss. Is anyone else having MT problems all of a sudden?


#2

Yes! Having the same problem … noticed on 7/16/04 at 12:55 PM. My “comments” are also down, getting an “Invalid entry ID ‘398’” message.

Does this have something to do with Dreamhost’s reboot last night? Anyone with suggestions how to handle this? (Researching right now and looking at this article from MT: “I changed hosts, and now I can’t log in to Movable Type.”

http://www.movabletype.org/docs/mtmanual_troubleshooting.html


#3

— Run “mt-check” on your site to see what you are dealing with.

[yoursite]/[mt directory]/mt-check.cgi

After running this, I saw that I had all the required modules installed and running, so I figured that my Berkley Database had been upgraded or changed through Dreamhost (meaning there were two different versions that were incompatible - Dreamhost vs. my files)

documentation: http://home.wangjianshuo.com/archives/20031027_invalid_login_on_my_movabletype.htm

NOTE: I’m on a Mac, so if anyone can post how to do this for Window users who aren’t accustomed to running UNIX commands, that’d be cool.

— So what you have to do is upgrade your .db files in your “db” folder. If you look at MT’s manual, there are directions there as well - I’m gonig to spell them out a little bit more - step by step for anyone not accustomed to UNIX (like myself)

documentation: (at bottom of page) http://www.movabletype.org/docs/mtmanual_troubleshooting.html

  1. Open your “Terminal” application (Mac users).

  2. Type “telnet [yoursite.com]”

(with unix, the first item, in this case “telnet” is the application you want to run anything following that are things you are telling it to do.)

  1. Login to dawber with your username/password (server name/password)

  2. Type “ls” (lowercase “L”)

This gives you a listing of your directory. You should see the root directory of your domains.

  1. Type “cd [yoursite.com]/[mt directory]/db”

cd = "change directory"
an example: “cd apple.com/mt/db

  1. Check the listing of the files in the directory to make sure that you are the right directory (see “ls” above)

===================================
NOTE: since Dreamhost does NOT have the suggested “db_upgrade” application, you have to run a more complicated approach (step 3 for those following with MT’s manual)

  1. The program used to dump the contents of your DB files is called either one of two things: db_dump, or db_dump185. To determine which program you need to use, first try running the following command in your shell account:

$ db_dump author.db

  1. If this command is successful, you will see a screenful of data dumped out. If it is unsuccessful, you will get an error message; in this case, try using the following command:

$ db_dump185 author.db

  1. Again, if the command is successful, you will see a screenful of data. If this also fails, then you will need to contact your hosting provider.

  2. Now that you have determined which db_dump program to use (either db_dump or db_dump185), you can dump all of the data from your old DBM files and load it into new versions of those files. To do that, try the following (substitute db_dump185 instead of db_dump, if necessary):

$ db_dump -f author.db.data author.db
$ mv author.db author.db.old
$ db_load -f author.db.data author.db
$ chmod 666 author.db

===================================
YOU SHOULD HAVE SUCCESSFULLY FINISHED AT THIS POINT. TEST YOUR SITE - HOPEFULLY IT WORKS! IF NOT, CONTACT DREAMHOST ABOUT YOUR PROBLEMS.

  • Brian

#4

Did this work for you? I tried it and it didn’t work for me, unfortunately. Didn’t you have to change all the files which end in .db or .idx in order for it to work? That’s the impression I get from reading the Troubleshooting files from Movable Type.

Thanks.


#5

Yes, it worked for me. I too initially thought that it would require that I had to manually change all the .db / .idx files (which is a pain), but I had tested it after step 10 and it was working again.

As I stated in my post, I have no Unix experience or understanding of the language. I searched around and posted the documentation that I found to be helpful. I also had a friend step me through the Terminal application (Mac OS-X) and explain a little bit about the steps (some of which is included).

Just a thought, but maybe double check that you are in the right folder - I would think that if you ran a command like that, that it would run it for all corresponding files within a folder structure.


#6

Quit complaining and switch to b2evolution. :slight_smile:

WebID: idorosen Donate.


#7

Here’s my own problem; this is the error message I’ve gotten:

Got an error: Connection error: Access denied for user: ‘Movable@genki.dreamhost.com’ (Using password: NO)

Can anyone explain this, please?

(Fyi, I’ve had tons of comment spam problems, and I don’t know how to FTP into my server.)


#8

I’m getting a similar error.

Got an error: Connection error: Access denied for user: ‘squarefreemt@ganymede.dreamhost.com’ (Using password: NO)

I’ve been using Movable Type for almost a year and this is the first time it’s happened.


#9

I can connect to your database just fine.

I do see the error you’re getting.

It’s odd that it’s saying “Using password: NO” - maybe that’s the problem?

I don’t think there’s a problem on our side that’s causing this, though.


#10

Dreamhost fixed my the problem on my site within 14 hours after I filed a support request :slight_smile: They say it was a random permissions problem and they’re still working on a general fix.