Movable Type hangs

apps

#1

Is anyone else using Movable Type on DreamHost having their scripts hang? When I go to save an entry, it stalls at the “rebuilding” stage whether it’s an individual entry or site-wide rebuild. It’s making me crazy, as the software has become totally useless.

Probably one in 15 tries goes through successfully, otherwise I have to keep trying and trying. And in the past few hours, it’s stopped working completely.

I’m using Movable Type v3.11 with MySQL and the “nofollow” plugin.

Let me know, thanks!
-David


#2

My MT installs are working well. You might try upgrading to the latest version. 3.15

Did this problem start when you made some kind of a change, or after you installed your plugin? That might give some idea of whre the problem is.

-Matttail


#3

It started all of a sudden, well after I installed the plugin. One day it worked great, the next I ran into problems, and now it’s just terrible.

I’m worried about upgrading, however. The last time I tried it (and it was on DreamHost), I tried upgrading from 2.64 to 3.11 (it was the most recent version at the time) and I got locked out of MT - and still haven’t managed a way back in (that install uses Berkeley DB, not MySQL). Luckily that was on a site I had just begun working on, but I can’t risk something similar with this site.

Either way, there’s no rational explanation as to why 3.11 shouldn’t be working just fine as it always has until a couple weeks ago. DreamHost doesn’t have an answer for me either.

But I appreciate your response, thank you.


#4

for the install you can’t access you might try out this little cgi script Mt Medic You can use it to create users and do some other stuff with out having access to MT at all.

As far as the most rescent upgrade is concerned, it sould be a bit simpler becuase this is not a big upgrade. It just involves a few new features and other bug fixes. The 2.6x to 3.1x upgrade was a major re-vamp.

You might want to think about that plugin, if the trouble seems to possibly correlate with it. You could search around the Mt forums for other people having that problem, and other people having problems with that plugin. You might also remove it, and re-write any files you changed for it with the original MT files.

-Matttail


#5

I’m going to look into this, though I have a feeling if the “nofollow” plugin (which prevents comment/trackback spam from being effective) were to be doing this, then the whole MT community would be complaining - and I haven’t seen that. And again, that plugin was installed for a couple months before any problems began.

I’m going to see about upgrading … hopefully it’s not too painful.


#6

[quote]and still haven’t managed a way back in (that install uses Berkeley DB,
not MySQL)

[/quote]

Not that this helps you much now, I’m afraid, but we highly recommend against using BDB if possible. We’ve had all sorts of MT-related complaints from customers that seem to be linked to its use, most of which are resolved by using MySQL instead.

Also, for what it’s worth, I’ve updated a few old MT weblogs to v3.X in the past, and didn’t have any significant problems. We also recommend updating because v3.X is being actively worked on, which means that there’s less potential for security flaws to remain un-patched…

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#7

I’ve been scrounging around the Movable Type’s website looking for an 3.15 UPDATE, but all I can find is the FULL VERSION to install. I can’t find any instructions or documentation (or posts in the support forums) that says what to do if 3.11 is already installed … am I simply supposed to upload all the 3.15 files and overwrite the old 3.11 files?

I have an inkling something might go terribly wrong with that process, but if that’s what I’m supposed to do …


#8

go to movabletype.org and log into your account. https://secure.sixapart.com/t/account Or create one if you don’t have it allready.

up at the top it should have a product listing. click on MT 3.15 Download link.

From the drop down menu select the upgrade version instead of the defult selected full version. Download zip version. Decompress, open the manual from the Docs directory. Carefully read and follow the directions and all should go well.

-Matttail


#9

Wow, don’t I feel foolish. I actually found that screen but thought they were listing recent files I had downloaded from Six Apart (and was displaying 3.15 because I had just downloaded the full version) … it had also listed a 3.6x version I had downloaded way back when. Whew, the simplest answer is usually the best.

I appreciate all your help buddy, thanks!