Movable Type and DreamHost


#1

I know that there are a fair number of people here who use Movable Type. Has anybody else been having problems with a lot of Internal Server Error (500) messages while running MT recently? I’ve been getting a lot of them and I know of two other people who are using MT on DreamHost that are having the same problem. Any ideas on what the cause of the problem could be?

http://www.muhajabah.com


#2

I’m seeing the same problem, and they’ve gotten quite more extreme since I’ve added plug-ins.


#3

If anybody has these problems, please contact support and PLEASE provide a URL (with any admin usernames/passwords to make it work) that is breaking!

It’s really hard for us to figure out what’s wrong when you just tell us Movable Type isn’t working…it’ll save everybody time to send a URL that reproduces the problem!


#4

I’ve been working on a new install of Movable Type. Dreamhost is missing a couple of necessary perl modules.

Specifically – File::Temp is not available at all (though it’s optional), and File::Spec is outdated (mt needs 0.8 or later).

I don’t know if that’s related to the problem in this thread, but it does seem to be an issue with new installs.


#5

Yes, I had to install those modules myself when I set up MT; however I haven’t had any problems with it and I don’t think it’s related to the current problem.

http://www.muhajabah.com


#6

I have already been working with DreamHost tech support for sometime. I posted this thread mostly to see if there was anybody else who is having the same problem or if it is just me. I do encourage everybody who is having the problem to submit a support ticket. I have been suggesting this as well at the MT support forums ( http://www.movabletype.org/support )

Thanks for your reply, Nate.

http://www.muhajabah.com


#7

Hi There-

I currently use Blogger for my site (http://www.gabeanderson.com/life) and just stumbled across Movable Type the other day. It looks really cool and quite a bit more powerful than Blogger. It will be awesome not to rely on Blogger’s site for posting, etc. and also to move all my content into a MySQL database.

Anyhow, there are obviously a number of DH users who use MT. I’m wondering if anyone might be able to provide me with a checklist of the best way to proceed in installing MT. (I’m assuming I have to do my own installation, even though some of the libraries might already be on DH, right?)

I’m even having a hard time getting the MT installation package (in GZ format) onto my server. I tried downloading to my Win2K machine, then uploading via WS FTP Pro, but when I went to gunzip MT-2.5-full-lib.tar.gz, I got this error:

[slash]$ gunzip MT-2.5-full-lib.tar.gz
gunzip: MT-2.5-full-lib.tar.gz: invalid compressed data–crc error

(I even ran dos2unix on the file prior to trying the gunzip command.)

I’ve tried to use wget to download the file directly to slash, but don’t know the exact path where the file is on MT’s servers. I’ve also tried to download the file via Lynx, and that didn’t work.

So if anyone could please offer guidance on installing MT (starting with the download), I’d really appreciate it. :slight_smile:

Thanks,
Gabe


#8

You shouldn’t run dos2unix on binary files… this may be your problem. dos2unix is used to strip dos carriage returns from text files. You might also make sure that you’re uploading in binary mode in your FTP client.

Also, a quicker way to inflate the tarball would be:
% tar xvzf [tarball]
or
% gunzip -c [tarball] | tar xvf -
(the first will only work on systems with GNU tar).


#9

Whoops! You’re right, Will. I guess the dos2unix was screwing things up. I was able to extract the files just fine. Thanks!

If anyone else has input on your experience installing MT, I’d still appreciate it.

Thanks,
Gabe


#10

[quote]If anyone else has input on your experience installing MT,
I’d still appreciate it.

[/quote]

Just an FYI, over the weekend I installed Movable Type onto one of our hosting servers and had no difficulties at all. There wasn’t anything weird about the install - we already had all of the dependencies installed, so that wasn’t an issue. Just follow the instructions (which aren’t as clear as they could be) and make sure your permissions are okay.

For what it’s worth, I was pretty impressed by it when I got it up and running. Problem is, I don’t have an awful lot of use for it right now, but it was an interesting experiment.

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#11

Yeah, I installed it yesterday to see what the hype was about, too. :slight_smile:

You’re right, the installation isn’t crystal clear in terms of your config file, but once it was up it looked rather interesting. I’d be interested to see this done ‘properly’ with an active participant.

  • wil

#12

Thanks for the input, Jeff and Wil. I’m going to work on the installation today and will keep everyone posted on my experience.

Since I am a rather active blogger, I plan to use MT often (as I use Blogger almost daily now).

-Gabe


#13

OK, so I seem to be stuck at the “Checking for Perl Modules”’ section of the installation guide:

http://www.movabletype.org/docs/mtinstall.html#checking for perl modules

I’m getting the 500 Internal Error message. I have checked out the troubleshooting for this error (here) and have confirmed that I’ve done everything on the list - the exception being uploading the file in ASCII text since that doesn’t really apply to me since I made no changes locally (rather, I uploaded the entire .gz file to my account, unpacked it there, and made all text changes to the .cgi files there.

I am not able to execute mt-check.cgi. Permissions are set correctly:

[slash]$ cd …/mt/
[slash]$ ls -l mt-check.cgi
-rwxr-xr-x 1 USER GROUP 4621 Oct 29 10:21 mt-check.cgi

Any thoughts?

Thanks,
Gabe


#14

P.S. I currently have the MT files in a secure directory protected by .htaccess, but I also tried running mt-check.cgi in an unprotected directory and got the same results.


#15

You need to CHMOD all mt-. files to 0775, too.

Did you check your error_log for the precise details of your 500 error?

  • wil

#16

Hi Wil-

Thanks for the input. You do mean 755, right? (Not 775.) 755 is what is specified in installation instructions. But yes, all *.cgi files are 755. The only mt file that was not 755 was mt.cfg, but I just changed it and tried again with the same result.

Here’s the error message from error log:

Premature end of script headers: /PATH/TO/WEBFILES/mt/mt-check.cgi

Thanks,
Gabe


#17

The directory has 0775 permissions; try changing the directory to 0755. Our default umask is 002 on some machines; you might change it to 022 if you haven’t already.


#18

Woohoo! That did it. Changing directory to 755 did the trick.

Thanks!

-Gabe


#19

OK, so now I’m on to the mt-load.cgi part of the installation and am getting this error:


Loading initial data into system…
Loading database schema…

An error occurred while loading data:

Access denied for user: ‘USER@slash.dreamhost.com’ to database ‘DB_NAME’ at mt-load.cgi line 54.

…even though I do have DBHost specified in the mt.cfg file.

Thoughts?

Thanks,
Gabe


#20

Did you put your password into the mt-pass.cgi file? I’m not sure of the name of the filename, but there is a file for your MySQL password.

  • wil