More problems uploading site


#1

Thanks for your help on my previous post.

I uploaded my site and I no longer get the index.

However, None of my images show up. My site is an art site. It’s ALL images. It validates with W3C. I looked in the image folders and the images appear to be there. I’m clueless. Can someone please help me.

The URL is www.leonardart.com

Thank you, Lindarose


#2

It appears the images got uploaded in the wrong format; instead of
http://www.leonardart.com/images/TLLogomerged2_28_em.gif
you have
http://www.leonardart.com/images/TLLogomerged2_28_em.gif.bin

Here is what .bin files are:
"MacBinary is a binary (non-text) format that encodes Macintosh files so that they can be safely stored or transfered through non-Macintosh systems. MacBinary combines the two forks of a Mac file, together with the file information (Name, Creator Application, File Type, etc) into a single binary data stream, suitable for storage on non-Mac systems."
from http://astronomy.swin.edu.au/~pbourke/dataformats/macbinary/

You probably need to change your preferences:
http://fetchsoftworks.com/FetchWebHelp/Contents/Preferences/UploadPreferences.html
Change “default upload format” to Binary (Raw).

:cool: Perl / MySQL / HTML+CSS


#3

Luckly you did not block access to the image folders. So I was able to view the directory of the images. The problem is all of your images have a .bin extention. rename all of your images to remove the .bin extention.
If possible I would shorten the name if possible, I have seen problems with images if the name is too long.
The link to the image does not have to be absolute it can be relative, meaning instead of http://www.mysite.com/images/photo.jpg you can use /images/photo.jpg the advantage of this come the first time you decide to rename your domain address.
Once you get this all sorted out, then it is up to you if you want viewers to see your images via a directory listing.
This can be taken care of by using a .htaccess file or placing a index.html file in that directory. Either one will redirect the user to a web page you choose.
Silk


#4

That won’t help. When you see a filename with multiple extensions, this means you actually have an original file that was converted to another type of file, eg:

  1. really_long_textfile.txt
  2. Archive #1 using tar and you have really_long_textfile.tar
  3. Compress #2 using gzip and you have really_long_textfile.tar.gz

So you can see you have to undo #3, and then undo #2, to get back to #1.

With the original poster’s situation, he is using a Mac. This operating system stores most files in two parts: a data fork and an application fork. The .bin extension indicates this is a file that is a combination of both forks. You can see this for yourself using a hex editor: his image files start with an application fork, and the data fork containing the GIF format data is later. Renaming the file is not going to remove the application fork, so the browser will end up with a corrupted image file.

:cool: Perl / MySQL / HTML+CSS


#5

IT WORKED!! thank you thank you thank you

[quote]You probably need to change your preferences:
http://fetchsoftworks.com/FetchWebHelp/Contents/Preferences/UploadPreferences.html
Change “default upload format” to Binary (Raw).
[/quote]
and thank for this and being so specific. It really helped.

I also took silkrooster’s advice and shortened most of my file and image names. I thought about that for the next site but needed a boot in the keester for this one.

How do you access these files. I’m on a Mac OS 9.2.2 and I don’t see them. I have to go to the library to see my site on a windows machine and it’s too late today. (small small town) I think blocking access is a good idea. I thought I saw something about that on this forum but I haven’t found it yet. I still need pretty simple directions. Is there a tutorial? I’m gonna google when I’m finished here.

Thanks again, I’m so excited!!

lindarose


#6

I figured it out. That search button worked just fine.

Thanks everyone, lindarose