Mod_rewrite - doesnt work

design

#1

i have read the posts here and havent found an answer to this one - my .htaccess is:

Options +FollowSymlinks

RewriteEngine On
RewriteBase /ping

RewriteRule ^user/showperson/([0-9]+)/([0-9]+)/$ user/showperson.php?wid=$1&uid=$2

i put the .htaccess in my top level directory for my domain, ping.net - my php scripts are all in the ping subdirectory

so this should change

http://www.ping.net/ping/user/showperson/2/5/

to

http://www.ping.net/ping/user/showperson.php?wid=2&uid=5

but all i get is a 404 - am i missing something here? - i have my php scripts running in apache not cgi-bin - i cant flip on cgi-bin until i get the mod_rewrite working - dont know if that matters

thanks for any help, i am stumped!


#2

It looks like your rewrite rule is giving you this:

http://www.ping.net/user/showperson/2/5/


Simon Jessey
Keystone Websites | si-blog


#3

how do you figure that? - doesnt RewriteBase set the base directory to ping?

well, i tried removing that and using the following:

Options +FollowSymlinks

RewriteEngine On

RewriteRule ^user/showperson/([0-9]+)/([0-9]+)/$ ping/user/showperson.php?wid=$1&uid=$2

this doesnt do anything either - i must be missing something obvious but i swear both the above snippets follow documentation on the web … anyone out there have a mod_rewrite for php that works on their dreamhost account (by way of example)?