MM_XSLTransform error in PHP page

software development


I am new to creating dynamic pages that “consume” an RSS feed, so I’m not sure if my problem here is in the XML or if it’s a compatibility problem with DH’s PHP.

Here’s what I’m trying to do:
In Dreamweaver, I’ve created an XSLT fragment ( to process the feed at Dreamweaver’s preview on my PC retrieves the headlines just fine. However, placing the retrieval code in a PHP page at DH returns an error: "MM_XSLTransform error.
Error opening"

I have a test page at if you want to see the error.

I can’t find any troubleshooting from Dreamweaver that fixes the problem, which is why I’m wondering if I’m doing something wrong in relation to PHP.

The code in index2.php as Dreamweaver wrote it is:

  • before is:
<?php //XMLXSL Transformation class require_once('includes/MM_XSLTransform/MM_XSLTransform.class.php'); ?>
  • in the page is:
<?php $mm_xsl = new MM_XSLTransform(); $mm_xsl->setXML(""); $mm_xsl->setXSL("noaa-alerts.xsl"); echo $mm_xsl->Transform(); ?>

Before you ask, all the files referenced above do exist. :slight_smile:

Any help would be appreciated!


It’s not possible to verify this without reading the code in your XSLTransform class, but I’m guessing it’s trying to use fopen() to access that remote data. This functionality has been disabled for security reasons. The recommended way to do this is to use CURL. If you can’t modify the code yourself you might contact the developer for an updated version.

You can read more about this on the Dreamhost wiki.

If you want useful replies, ask smart questions.


Ah! That may be the problem. I’ll edit the file and let you know.


Ahhh, I’m going crazy trying to get this functionality to work with dreamhost. Can anyone that has used Dreamweaver 8 to do a PHP based XSL transform let me know exactly what code they had to change or if there is an updated Dreamweaver MM-XSLTransform that doesn’t use fopen?


I finally found a temp fix using cURL on an Adobe forum from blessed user DEPearson. It’s towards the bottom: My work around for the "MM_XSLTransform error on Servers with allow_url_fopen set Off. I tried it and it worked just fine for me.