Mediawiki upgrade problem

apps

#1

hey there -

a few days ago i used the one-click install to upgrade my mediawiki version on my http://stealthiswiki.nine9pages.com subdomain. i dont have any plugins installed.

now we’re unable to edit any pages. clicking on the edit link brings this “Database Error” page:

A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

(SQL query hidden)

from within function “Block::load”. MySQL returned error “1054: Unknown column ‘ipb_anon_only’ in ‘where clause’ (mysql.stealthiswiki.nine9pages.com)”.

if it helps in arriving at the problem, my custom logo, which was assigned the default path (i just replaced the art with another file using the same name) is now missing.

i have NO idea how to troubleshoot this. if anyone has any suggestions, they would be greatly appreciated.


#2

Don’t forget to, in your wiki directory, do

‘cd maintenance’
’/usr/local/dh/cgi-system/php5.cgi update.php’


#3

I have done this on my MediaWiki installs and I receive the following error:

[temple]$ /usr/local/dh/cgi-system/php5.cgi update.php
X-Powered-By: PHP/5.1.2
Content-type: text/html

MediaWiki 1.8.2 Updater

No superuser credentials could be found. Please provide the details of a user with appropriate permissions to update the database. See AdminSettings.sample for more details.

What am I missing?

Thanks,
Chris.


#4

OK, I have since been able to remedy this by modifying update.php to have the correct (non-default) values for $wgDBadminuser and $wgDBadminpassword.

Is there a better way of doing this without resorting to editing the update.php file?

Cheers, Chris.


#5

Just to clarify… I added this to the top of /maintenance/update.php

$wgDBadminuser = “mySQLusername”;
$wgDBadminpassword = “mySQLpassword”;

Where mySQLusername and mySQLpassword are the ones used to access your mySQL database, not your Wiki l/p. For whatever reason I kept trying my login and it wouldn’t work. duh.


#6

I get this!!

MediaWiki 1.9.3 Updater

No superuser credentials could be found. Please provide the details
of a user with appropriate permissions to update the database. See
AdminSettings.sample for more details.

but I’m using the DB username with rights to acces to the wiki databae


#7

Copy AdminSettings.sample to AdminSettings.php, and edit the information in it to reflect your database info.

emufarmers.com
Very little to do with either emus or farmers!