So I upgraded to Mediawiki 1.22.6 today on my VPS and when I try to run the update.php file form the shell I see the error:
You are using PHP version 5.2.17 but MediaWiki 1.22 needs PHP 5.3.2 or higher. ABORTING.
Check if you have a newer php executable with a different name, such as php5.
Thing is, I am running php 5.4 currently, I have confirmed that with the -v command line prompt.
So what am I doing wrong?