Media upload/add/insert has stopped working in Wordpress site

wordpress

#1

I can’t add media, either in pages, posts or in the theme to change background images.
I haven’t worked with this site for a month or so, so I’m not sure when it happened.
When I try to add an image, through the theme (ie, not directly as css), the “Add media” frame appears normally. If I try to upload an image from my computer, the default, the Select Files button does not work and the browser uploader link does not work. Attempting to add from the Media Library brings up the list, but the Show links do not show the expanded image info, and don’t allow me to add the image.
Trying to add an image on a page or post displays the same problems.

At one point I had foolishly enabled PageSpeed optimization and subsequently the background image, which still reflected the ugly link that pagespeed creates, disappeared, which is what precipitated finding out about the problem. I did disable this mess several months ago, but I’m not convinced this didn’t play a part.

Not having fully learned my lesson, today I enabled Cloudflare, thinking that since it was NOT a beta feature, nothing terrible would happen. It may not have anything to do with this problem, but now I’m suspicious. I did disable it, though that has made no difference.

I’ve de-activated and deleted the theme framework, Headway, and then downloaded a fresh copy and re-installed it. While the site was under a different theme, I tested the Media upload again and it still failed, so I re-activated Headway. I have an older version of the site, that I reactivated and it shows the problem too, and I’m almost positive that media upload worked when that one was decommissioned. I’m running the site on an up-to-date Wordpress, and the older version was an earlier WP and it still failed.

I’ve tried repairing/optimizing the databases. No joy.

Any ideas why this is happening? And better, what to do about it?


#2

Nothing in either pagespeed nor cloudflare should impact your file uploads. You have multiple domains, so without knowing which one you’re having an issue with…

Make sure you’re not uploading a totally ginourmous image (like 2000px by 5000px). Try something small.

If that still fails, we’d have to start with the usual debugging methods. Turn off all your plugins and see if you can upload an image. If that works, start turning them on one at a time. If that doesn help, switch your theme to TwentyEleven and see if it works.

Also make sure you’ve upgraded everything :slight_smile:

I’m presuming you mean when you go to look at your images in the media upload, they say something like 0 x 0 px for image size?


#3

Very hard for me to look at without knowing the domain. It sounds like you might have Rocket Loader turned on, which potentially can impact editors and other items that rely on JavaScript, so try turning that off in your CloudFlare Performance Settings.

I would also strongly recommend creating a CloudFlare Page Rule to exclude the admin section of your site.