Mbstring PHP extension missing


#1

Hi there, I’m 3 hrs into a support ticket answer about this and have done some searching around but I’m still not sure why its happening to me.

I have a few friends on DH and none of them get the error message in phpmyadmin like I do…

“The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.”

I read one post that said DH doesnt load that extension, but if that were true wouldnt everyone get that warning? Getting this message straight out of the box, worries me a bit…

I’d appreciate it if anyone has some help in this, Ive got a few db’s to start to get my sites back up…

TIA

oh and hey this is my first post and first day at DH

:slight_smile:


#2

ok, well I got a response, albeit an “automated” one at best.

“We have disabled mbstring in our system due to the may issues it caused. You will have to use an alternative or find help form other customers who have had this problem through our discussion forums”

not a ringing endorsement for a new customer… but I went ahead anyway with my database setups…

I posted this in case anyone else is wanting to email tech support over it, they can save time…


#3

This error comes up in PHPMyAdmin if you change your language setting to a language that requires the mbstring extension.

  • Dallas
  • DreamHost Head Honcho/Founder

#4

ah, I was wondering about that, although I didnt touch any of those settings, could you tell me what to set it on to remove the warning?

thanks


#5

Hmm, well if you didn’t change anything there may be something else going on. Setting it to English should work fine. Contact our support team (again) if the problem continues for you.

  • Dallas
  • DreamHost Head Honcho/Founder

#6

yeah I didnt touch anything, Ive set up two db’s and they both are set as:

Language : English (en-utf-8)
MySQL charset: UTF-8 Unicode (utf8)
MySQL connection collation: utf8_general_cl

is that default?


#7

I think those are the mysql settings rather than your phpmyadmin preferences. I was referring to the phpmyadmin preferences.

  • Dallas
  • DreamHost Head Honcho/Founder

#8

hmm, I dont know, honestly never knew there were prefs for myadmin, those are just the settings under the phpmyadmin title bar…

if you tell me where to look I’d be glad to check it out…


#9

I have those same settings, but I don’t get that message.

Actually, I used to get that message, but it’s not there anymore.


#10

It’s right when you first log into phpmyadmin. There’s a popup menu on the main page labeled ‘Language’. The default setting seems to be "English (en-iso-8859-1).

  • Dallas
  • DreamHost Head Honcho/Founder

#11

I dont get pop ups when I log in, the only Language setting I have access to is the one I posted above and its under the phpmyadmin title bar, and iso is not a choice in any of the drop down languages they are all utf…


#12

If you haven’t yet, you should write into our support team so they can help you out.

  • Dallas
  • DreamHost Head Honcho/Founder

#13

I did, I posted what support said in my second entry in this thread, I was told to come here. (after a 4 1/2 hr wait)


#14

I am getting exactly the same error/warning message as lokjah, and I also have not changed the language settings for either MySQL or phpMyAdmin. I shan’t bother contacting Support if all they are going to do is to send me back here! :frowning:

If memory serves, English iso-8859-1 was the default phpMyAdmin language set in the previous version of phpMyAdmin; but now, in phpMyAdmin 2.6.2-pl1, the only language options for phpMyAdmin are listed in a drop down menu, and they are all in the form of “language (lang-utf-8)”, e.g. English (en-utf-8).

  • marsbar

#15

Oh, whoops. Sorry, I had forgotten how the thread started!

I’m not sure why the phpmyadmin I’m looking at is different than the one you’re seeing. I’ve talked to our phpmyadmin guy and the error is apparently harmless, though it is annoying.

We’re very close to updating PHP to have the proper mbstring support so the error will go away in next week or so.

Sorry for the run-around! I thought it was a different problem.

  • Dallas
  • DreamHost Head Honcho/Founder

#16

thanks Dallas.


#17

Many thanks! The error/warning message has gone away for me. :slight_smile:


#18

Just subscribed.
Hello everyone.

I’m glad your mbstring issue is over.

Looks like it popped up for me !! (I am not sure it is new because I haven’t PHPMyadmin’ed for a while.)

My settings are
lPHPMyadmin anguage French (fr-utf(8)
Mysql charset (utf8-general-ci)
Mysql connection collation UTF-8 Unicode (utf8)

Re tables which contain text (articles), the collation is latin1-swedish-ci, except for one field (varchar) which is latin1-bin for whatever reason ???

As you know, we have a lot of accents in French but apart from the red warning when entering PHPMyadmin, accents look alright … as far as I can see since I can’t tell about BLOBs with PHP Myadmin.

Anyway, the red flag is pretty disturbing…

Thanks for any enlightements.
Sorry for my English which looks sometimes … strange.


#19

G’day and welcome, mybeau.

I spoke too soon: the mbstring error/warning message has returned!

This is all very curious; I am quite certain the message was not there the last time I checked.

My settings are almost identical to yours, except for the PHPMyAdmin language preference where mine is set to English (en-utf-8).

Cheers,
marsbar


#20

Thanks for welcoming me. marsbar

I checked another site and database I have on another domain and account on dreamhost.
BTW it is the very same database structure I have used to test dreamhost.
Language and charsets are the same.
No warning/error message…

The difference is that I get the red flag with PHPMyadmin 2.6.2 Pl1 and do not with PHPMyadmin 2.6.1 Pl3 which runs on my test site’s server…

Well. I don’t know what to do with this bit of info. I thought you’d be interested to know.