Max_upload_limit not working


#1

Hi,

First of all I want to say that I’m a designer, not a programmer, so excuse me in advance if I ask somthing stupid :slight_smile:

My site is using a flash CMS which uploads trhough PHP. The thing is that cannot upload large files.

I was told to install PHP5 in my local so I’ll be able to change the max_upload_limit in the php.ini file. I did install PHP5 as the wiki explains and modified the php.ini (both, max_upload_limit and post_max_size) and still not working.

After installing PHP5, I got lost with the .htaccess part of the tutorial. What I did was to still the .htaccess file from one of my drupal sites, delete its content and replace it with the shown below:

Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

<FilesMatch “^php5?.(ini|cgi)$”>
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS

…then, I uploaded the file to the root folder of my domain. After this, when traying to access to my site (http://elpuntografico.com) the error message below was shown:

"Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator, webmaster@elpuntografico.com
and inform them of the time the error occurred, and anything you might
have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use
an ErrorDocument to handle the request."

So I figured I must screw the htaccess part out and so I deleted the file itself from the server. Now my site it’s shown correctly and I dont get any errors at all, but still not uploading large files from the CMS.

Does anybody knows how to solve this?

Thanks in advance!


#2

I remember a thing I did, this maybe helps to find the problem.

At the PHP5 script part, it says to replace "DOMAIN=“YOURDOMAIN.TLD” with my domain. What I wrote was "DOMAIN=“elpuntografico.com”, but I’m start thinking that I was asked for one of these, "DOMAIN=“elpuntografico.com.TLD” or "DOMAIN=“elpuntografico.TLD”. Am I right? If so… I messed up big time…


#3

One more thing,

I created a version.php (http://elpuntografico.com/version.php) file to check out the version of PHP my site is using and is not using the PHP5 custom installation I did on my local, instead is using the PHP5 general installation of the DreamHost server.

That’s why the changes I’m doing in the ini file aint working.

Any ideas?

Thanks.


#4

This is a much easier way to increase upload_max_filesize:
http://wiki.dreamhost.com/PHP.ini

-Scott