Max_input_vars not updating on 'dreampress'

vps

#1

Hello…this is my first time posting here. I’m hopeful for a helping hand as I don’t wanna leave Dreamhost but am starting to feel like I’m throwing money away.

I’m trying to update the phprc file on my recent upgrade to dreampress (which was a nightmare as they migrated the site improperly which took me down for days)…with zero luck.

I have woocommerce on the server and am trying to get over 50 variations per product setup…but no luck. I’ve read on woo docs that I need to increase ‘max_input_vars’ from 1000 to 2000 so the vars don’t timeout.

(towards bottom of page)

I followed the instructions Dreamhosts non-existent support shared here:

http://wiki.dreamhost.com/Php.ini#phprc

(at least I think I did…) by editing the phprc file to show the following contents:

; {{{ The following lines were automatically added by DreamHost
extension=xcache.so
; }}} That’s all from DreamHost

php_value max_input_vars 2000

but my phpinfo shows its still at 1000…plus a test setup of 49-51 vars on my test product does not save properly… any thoughts? I’m close to moving to wpengine where I can get help as I’m REALLY TURNED OFF from the recent chats I’ve had with dreamhost after being a loyal customer of theirs for years. I’m giving this a last shot here to see what’s available.

PS - thanks for letting me vomit a bit about the recent woes…just needed to get that off my chest :smiley:


#2

php_value is a .htaccess directive; it’s not needed in phprc. What you need is simply:


#3

Thanks - I’ve updated this in phprc, rebooted the server and it works now.

Thanks so much - I couldn’t have set more than 50 variations on my woocommerce products without your help. I was prepared to leave dreamhost and now I don’t have to.


#4

Hey guys! THANKS!!!

i did exactly what nightmarepress did.

  1. I copied

into the phprc file.
2) rebooted the server.

It only worked after I rebooted the server. I didn’t have to mess with .htaccess.