Max_execution time, 500 internal server error


#1

Hi everyone!

I am new to Dreamhost, so please pardon my ignorance! :slight_smile:

I recently uploaded my php files to my DH VPS. When I was developing my files on my MAMP, I modified my php.ini file so that my max_execution_time was very long (3000s). I tried doing the same modification to the DH VPS php.ini file, but after some “500 internal server error” responses, and some troubleshooting, It seems as though there must be a hidden setting somewhere that won’t let my max_execution_time go any longer than 120 seconds. Is there another setting that I should know about and change, so that my max_execution_time can be bumped up and followed? I read that there might be a way to do this via modification of an .htaccess file, but I am not sure that will resolve my issue.

Just to be clear, there wasn’t any written setting (in my php.ini file) regarding max_execution_time, so I added that line of code. Apache is recognizing any changes I make to that variable, up to 120 seconds (i.e. up until 120 seconds, I don’t get the 500 internal server error at all, just a fatal error, max execution time exceeded warning).

Can anyone help me figure out where the hidden variable I need to adjust might be… or perhaps help by enlightening me regarding a slick (or not-so-slick) work-around?

Thanks in advance! :slight_smile:


#2

Just tried doing a similar setting in my DH VPS and it didn’t work out by simply changing the variables. Could be a bug or something because it should work that simple. It’s gonna be a lot more confusing when we try it via .htc