Mambo & Coppermine config issues

apps

#1

I was able to install Mambo and Coppermine without any errors. However, when I try to add modules/components in Mambo or upload pictures to Coppermine, I get all sorts of errors that, according to the docs for both programs, could be permission settings on directories. I’ve checked and can’t see anything in my user directories on my DH account. Has anyone else used either program on DH and, hopefully, been able to configure it?


#2

I’ve got three coppermine installs running now and had a mambo install up for a while, modules included. Are you running both with php as cgi? Most times when I get stumped with permission problems that seems to fix it for me.


#3

Hi – thanks for answering.

Yes, I have PHP as CGI set on the domain.

With the Mambo site, I have been able to enable a new template and install a couple of small, simple components, but nothing complicated (like Events Calendar or Guestbook). The download zips are fine, because they install perfectly in my local installation. When I try to upload and install to the DH-hosted site, I get a couple of consistent error messages. One is Unrecoverable Error something about PCL_Zip (-10). Sorry – doing this from memory on a break at work and don’t have my notes. From the little I’ve found on the Mambo support forums, this seems to indicate either a compression error – possible during the download – or a permissions problem on the directories. If that were true, the couple of things I did install wouldn’t have worked, either.

If I try to use the “Install from Server” option, I get similar errors. I discovered, however, that the Ako_book (Guestbook) component was half-installed. There is a table for it in the database, and there’s a reference to it in the admin directory on the server. But, there’s no corresponding sub-directory in the components directory, like there is with other components.

I get similar errors with Mambots, also.

With Coppermine, everything was going great in the setup. Then I tried to upload some pictures, and the error I got was something about improper file format (again, sorry I don’t have my notes at hand). It would only allow me to upload one image in one album, either from my local PC or from the FTP’d files on the domain account.

So, I’m kinda stuck. I’m thinking I should just dump the SQL from the DH account into my local Mambo installation, install the components, modules, and Mambots I want to use, then dump the database and all the directories back onto the DH domain account.

But, there has to be a better way!


#4

I’m trying to get coppermine running on my site but I can’t seem to get it to find the ImageMagick path ‘/usr/bin’

Is this path correct? Are there features in the dreamhost web panel I need to install other than the MySQL to get it working? Thanks in advance!

-AC


#5

/usr/bin/ works for me. (Running php as cgi, if it matters.)