Mail certificate in Mac OS X 10.5 Mail


#1

I realize that OS X 10.5 was just released but have noticed that the new version of Mail doesn’t recognize the certificates like 10.4 mail did.

The instructions for 10.4 don’t seem to apply any longer.

Any workaround to get 10.5 Mail to recognize the certificates?

Thanks.


#2

I went to dreamhost’s wiki and clicked the certificate link and downloaded it again. I then followed the instructions and have gotten the new Mail to send and receive messages but it seems that it can’t move them around on the server. It is a partial solution. Hopefully they will update the wiki soon.


#3

I tried doing the same thing but when I had to choose X509Anchors from the drop down menu within the Keychain Access program, the X509Anchors wasn’t an option.

Which did you choose or did you see it as the 10.4 instructions show?


#4

I chose the default that came up with I think was Logins. The next box it took me to asked me to trust the certificate or not. If you click the arrow next to the Show Details item, it gives a pop-up with X509Anchors selected. Click Always Trust and you should be good to go. Just find out what your server name is and follow the rest of the instructions as much as you can. I still can’t delete from within Mail because I keep getting IMAP command errors or something like that. Let me know if this helps.


#5

You can create a new keychain by clicking on File: New Keychain in the Keychain Access app. That way you can create the X509Anchors keychain to hold the Dreamhost certificate. It seems to be working fine for me. I don’t have any problems moving files around like you said in an earlier post. Hope this helps.


#6

You should install Dreamhost CA certificate in the Login keychain if you like to have it only for you or to System keychain when it is accessible to every user in that machine. I installed it to System keychain and its working just fine.

  • mikian

#7

I think I did what you guys suggested, but it still isn’t deleting messages or moving them. I might need you to walk me through the process. After I create a new keychain, then what?


#8

Hey guys, just thought I’d spread the word, but if you uncheck “store deleted messages on server” from the Mailbox Behaviors tab for each account, everything works. Hope it helps.


#9

I just installed OX 10.5 (Leopard) and am not having much luck with the Mail client, despite following the Wiki. I am unable to see any messages in the inbox, though I can send just fine - also, the messages in sent, etc, are all very old - the most recent aren’t there. The inbox folder is at the top left (along with “Drafts” “Sent” and “Trash,” while my “account” folders are below, none of which is an “inbox.” I tried putting the mail sever name at the front of the ingoing and outgoing server spec (i.e. servername.mail.domain.com) but that wasn’t found, it only worked with “mail.domain.com.”

What’s next?


#10

I get
"The server error encountered was: The server “*.mail.dreamhost.com” cannot be contacted on port 465."
I get the same problems on port 587 (which is suggested for 10.5 on the wiki page).
This is immediately after upgrade.
If i try "spacey.mail.dreamhost.com’ the connection just spins.
I’ve tried installing the cert on both login, and then system, no luck with either.
Anyone have any ideas?


#11

I got it to work by using

{mailserver}.mail.dreamhost.com (not sure about the port, didn’t change it)

username: emailaddress@mydomain.com
password: {password}

emailaddress and password are those used for webmail


#12

yeah that seemed to work…using the default port 993