Magic_Quotes


#1

How do I enable this? I’m getting this message: http://www.usgaming-network.com/bans

It says Magic_Quotes for PHP isn’t enabled… Yet I do not know how to enable it… I thought it would be enabled by default, but whatever…


#2

Magic Quotes is enabled when running PHP4, so you can always switch to using that. If you want to continue with PHP5 (where the option has been wisely disabled), I recommend using addslashes() and stripslashes(), and mysql_real_escape_string() for working with MySQL.


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#3

How would I switch to PHP4?


#4

In the DreamHost control panel, select Manage Domains and then [[color=#0000CC]Edit[/color]] your domain. You should see the option to switch between the two versions.


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#5

magic_quotes == EVIL. They do not protect you in any shape or form. If a PHP Script requires them, I highly suggest looking for another one. Sorry, but they bad and in PHP6 that won’t even be a possible option anymore (it’s getting flat out removed from PHP6 not just disabled).

magic_quotes are the Devil.


yerba# rm -rf /etc
yerba#


#6

thanks