Mac OS X 3.2 w/Leopard IMAP issues pls help!


#1

Hello everyone –

I just got a new Mac Mini w/OS X 10.5 Leopard. Currently I have my Dreamhost mail account set up and operating just fine; however, it does not use SSL or the security certificate as described in the instructions on the support wiki. Furthermore, my current settings do not have the “looney” prefix on the mail server names, not to mention my username is different than what the instructions on the support wiki say it is supposed to be.

Because I want to be able to use the security available with SSL, I followed the instructions on the support wiki to the letter for setting up email to work with OS X Mail 3.2, including installing the security certificate. I even went so far as to create an “X509Anchors” keychain just in case the “login” keychain would not work properly. Despite these measures taken, I cannot send or receive any email with the new computer. It gives me an error message stating that the server cannot be contacted on port 587. The same is true when I try 993, 465, and 143.

I don’t claim to know everything about how to configure mail servers, but I know how to follow instructions, so I have no clue what I am doing wrong. To make matters worse, I tried duplicating the settings I had used for my other computer, without SSL [as on the other computer], and I get no error messages, but cannot see ANY of my messages or mailboxes, and do not see any option to download them.

Any help you can provide would be very much appreciated. Thanks!

Brandon


#2

The good news is that it works for me, so it’s possible.

First, get the email server name via the Panel’s Account Status link in the upper right corner. Your in and outbound mail server should be set to thatname.mail.dreamhost.com
The username should be you@yourdomain.com and authentication should be set to Password.

Turn on SSL for in and out mail servers, and that’ll set the port. I think that Leopard makes it much easier to authenticate the certificate. Just Show Details and turn on the Always Trust checkbox. I’m not sure if you have manually add the certifcate to your keychain anymore.

And be sure to use the advanced settings to set the IMAP Path Prefix to INBOX

Give all that a try. I’m hoping it works out without having to muck around with the certificate.

Or it could be that your ISP is blocking those ports.

-Scott