Mac OS 10.5 Mail won't send :(


#1

Hi,

I know this is going to come across as a stupid question but if anyone can help it’d be much appreciated.

I set-up my mail on both my iPhone 3GS and my Mac just as it says on the set-up help on this site but neither can send mail. I receive mail on both and I think at one point mail did send briefly from my Mac but neither have worked since I set up in June. I have checked the connection and everything seems fine from this side. I’ve tried checking this site for help but I’ve become a bit stuck as there seems to be no-one as far as I have looked with this particular problem (apologies now if I have missed something).

If anyone can enlighten me at all it would be very much appreciated.

Thanks.[hr]
Oh I forgot to add, when I use the webmail that dreamhost suggests I can send mail >_< It’s just such a pain to access.


#2

Here’s the setup I used:
http://wiki.dreamhost.com/Mac_OS_X_Mail_10.5

Some ISPs block Port 25, so try 587 for outbound mail:
http://wiki.dreamhost.com/SMTP_Port_587

On the iPhone, turn off wireless and try sending via the 3G network to see if your ISP is blocking, whereas AT&T doesn’t, as far as I know.


#3

Thanks for the suggestions but I set up via the set up you suggested and the port hasn’t made a difference. This problem occurs regardless of what network I use as I use both my Mac and iPhone in other places with completely different networks with no avail.

Thanks so much for the suggestions tho.


#4

Is there any indication that it’s actually connecting to the server to send? Or is it giving you a helpful error message?

As a quick test on your Mac, fire up Terminal and type in:
telnet mail.example.com 25

And see if it makes a connection. If it does connect, just type HELO and wait a bit for a response. That should tell you which mail server you’re on. If that all still looks good, then I suspect it’s a username (entire email address) or password issue.


#5

I’ve tried so much with my account. Having server 587 on my mac makes no difference whilst my iPhone won’t accept it.

The mail on my mac comes up with the message that it can’t send the message using the server and to try a difference outgoing mail server which I don’t have. When I check the connection doctor it says that the connection has succeeded with login and no login required.

I tried the suggestion with terminal and it says after I’ve typed the suggested:

mail.example.com: nodename nor servname provided, or not known

I assume this means there is a problem with the connection which is confusing considering the connection doctor and that I do receive mail.

With my iPhone the error message says that the server has rejected the mail so it can’t send regardless if where I send it.

Thanks so much for the help so far. I’d really appreciate it if there is anymore anyone can suggsest either to help or just the cause.


#6

I’ve been having the same problem intheradio had and can’t figure it out.

Using Terminal, port 25:

telnet: connect to address xxx: Connection refused
telnet: Unable to connect to remote host

Port 110:
Trying xxxxxx.xxx.xxx
Connected to mail.url.com.
Escape character is ‘^]’.
+OK Dovecot ready.

Port 587:
Trying xxxxxx.xxx.xxx
Connected to mail.url.com.
Escape character is ‘^]’.
220 homiemail-a59.g.dreamhost.com ESMTP

Using any of these ports in Mac Mail doesn’t help.

I don’t get it; a few days ago i could send no problem, and I can receive no problem, so it must be the outgoing server, right?

Any ideas?


#7

Port 25 tells me that your outgoing mail won’t work. I’d guess your ISP is blocking it, which is why 587 is available and looks to work. Port 110 is incoming, so don’t use that port.

Make sure your outgoing settings are correct (no SSL, etc), full user@example.com and password.
http://wiki.dreamhost.com/SMTP_Port_587#Mail.app


#8

Thanks. I’ve tried this, and I’ve also created a custom DNS record with my registrar to no avail. This has been going on since the server merge and I’m sooooo sick of using squirrel mail.


#9

Have you contacted Support?

I just discovered that Mail.app has a pretty slick debugger: Window menu -> Connection Doctor.
Click on the failing account, turn on Show Detail, and then click Check Again.


#10

This seems to be an intermittent problem for me. My best theory is that it happens when I’m uploading a large file. It’s very frustrating when it occurs since I haven’t figured out a way to cancel the sending process so I can select my ISPs out going mail server. You just have to wait for Mail to go through it’s failure process. Usually, it requests my password when it fails, and when I enter that it sends it fine.