Ls -l not giving full info


#1

I’m using ssh to log into my account. The ls -l command does not show where symbolic links point to. Is this a problem with ssh or some setting in Dreamhost ?


#2

Sorry, I discovered my problem. I used scp -r to upload a directory structure. During the upload, scp replaced symbolic links to directories with full directories. So ls -l was indeed working correctly. Now I need to go discover why scp doesn’t upload symbolic links as links.


#3

I don’t think scp has that facility. You probably want to wrap up your directory structure as a tar or zip (which is better anyway, since you don’t run the risk of scp creating files that you’re not expecting).

Note that with zip, you must use the -y flag (otherwise zip will include the original file instead of the link). Link inclusion is the default behavior with tar (tar -h will invert that behavior)