I’ve noticed in the access logs that it displays the hostname, rather than the IP address. Is there any way to make it so logs only show IP addresses instead of the hostnames? I find the way it’s set up now inconvenient. One of the reasons I moved away from my old host is because they had switched logging from numerical IPs to hostnames, and I was not aware that DreamHost did the same thing.

Are you looking at raw logs or statistics reports?

Statistics reports can change at Panel, Status, site statistics, Edit, Edit, uncheck “Enable DNS lookups for numeric IP addresses”

I was looking at both. In the options, “Enable DNS lookups for numeric IP addresses” was already unchecked, and yet, in the site statistics, it still showed mostly hostnames.

So there’s no way to make the logs/stats page display numerical IPs rather than host names?

My logs always show IPs. You have to uncheck the option and give it time to update. At least a day for daily, and not sure for monthly. If something is stuck, try a support request. It should work either way.

As I’ve already stated, by default, it was unchecked.