Local Server Path - What is it?


#1

Hi there -

I’m using a script that requires that I add the “local server path to small images folder” to an admin field.

I’ve added the image folder…

But, I don’t know what the local server path would be on the site that I just set up.

I’ve seen some hints like:
"/usr/http/web/images/cp/small/"

But, I don’t get it.

Any ideas from the experienced DH crowd?

Thanks for your time.

Daz.


#2

atacama who runs the website wombatnation says that

my MT install uses a site path that he says is a no-no, but it’s something like this:
/home/.unbelievable/user/domain.com/blog
The only thing is that I don’t have a clue how you’d figure out that server name (.unbelievable) becuase that’s like a data glob running on a physical server or something… it’s not the server that the panel lists for my site. but I think the fist example should work for you.

-Matttail


#3

this is mine

server im on is “yen”

/home/.barbie/twista/mysite/forums/html/

GottaDeal.com Deals & Coupon Codes. Why Pay Retail?


#4

Thanks for the info.

Looks like I’m on .quid server, but my paths are still not working.

/home/.quid/username/domainname.com/images/subimages/subimages_1/
/home/.quid/username/domainname.com/images/subimages/subimages_2/

I’m trying to get my admin to write to the subimages (1 & 2) folders.

I don’t know what the deal is.

Thanks for the help guys. It was more than I knew.


#5

have you enabled write permissions for thoes directories? that might be the problem, rather than an issue with the paths.

-Matttail


#6

Yeah, I have.

I’ve double/triple checked them. 777 access from the main images directory on down.

I’ve been using a Dreamweaver extension to do it… and I can see that it’s being changed in the ftp logs.

I’m hopeful that I’m close… but I’m running out of stuff to try.

I also lowered my security level in dreamhost this morning, hoping that would help.

– Daz


#7

did you try taking out ‘.quid’ and see if that works? I was looking back through some old posts, and the path should work just fine with out it.

.quid is what Jeff calls a dataglob and it’s possible that it can change from time to time. but /home/username/domain.com/ is suposed to keep working.

I am wondering if your script is not actually looking for the full site path, but just a path to the directory it’s going to write to, from it’s current location?

-Matttail


#8

I’ve tried it both with and without .quid, though I’ll go and try it again anyway. I’m about 78% insane with this right now.

:slight_smile:

But, thanks for the tip.

–d


#9

Holy Crud!

I’ve tried this before, but I didn’t “save” my settings before attempting it. This time, it is doing something different, and actually MIGHT be working.

Thanks much for everyone who took the time out to advise me. I’m just a graphic/web designer with great pixels but little code powers.

:slight_smile:

  • d

#10

I recently had a similar problem to this one…
You can use some very simple PHP to get your local path.
Insert this snippet into your HTML/PHP document…

<? echo $DOCUMENT_ROOT; ?>

anywhere you place this in your HTML the local path to www.mydomain.com should be substituted. Sorry if this is eroneous… might not be what you need at all.

John


#11

Thanks much.

It’s actually working now. I just needed to eliminate the servername, and all was well.

Thank you.

Daniel