Ln -s folder for ftp user returns permission denied


#1

Got a problem… hope someone can shed some light…

  1. Created a new user

  2. Created a new group with myself and that user in it

  3. Logged into my account, created a folder for them in the hosting so it resides in the following pathing

/home/myaccountname/domainname/userfolder

  1. changed the folders group

[quote]chgrp grpname userfolder
[/quote]

this accepts the change which confirms the group is active…

  1. changed chmod on the folder

[quote]chmod 755 userfolder
[/quote]

(and also tried 777)

  1. logged in as the new user in the shell and create the link using…

[quote]ln -s /home/myaccountname/domain/userfolder /home/username/

[/quote]

this creates the link as expected and when using >ln -g it displays a correct relationship to the linked folder
how ever it refuses to let that user via sftp (and also in the shell) to dir into the linked folder.
even while logged into and using the users account…

[quote]cd /home/myaccountname/domain/userfolder
[/quote]

just returns permission denied

what am I missing?


#2

Two guesses:

  1. You turned on Enhanced Security for your user. This is in the panel for Users -> Manage Users -> Edit. You may need to contact Support to fix permissions after you turn this off.
  2. If it’s not #1, then it may be because the parent directories (USER and DOMAIN) aren’t group readable. This is similar to #1, but more under your control.

-Scott


#3

thanks for the reply
k it’s not #1

if I understand you right re #2 if the domains .com folder is grouped to the p##3 default group but not the other one the permissions don’t filter through

gunna go check that now…
cheers


#4

legend that fixed it
thanks for that much appreciated :slight_smile: Was def missing something! :slight_smile:


#5

Hmm,

I am having the same issue yet the solution doesnt seem to be post here? Do you remember what it is that you did?