Lighttpd with XCache


#1

Hello!

I’ve been trying to configure my php.ini on the VPS. I wanted to increase the xcache.size from the default 16M to 64M. However, every time after I make the edits and reboot the server, it does not change anything. When I go into /etc/php5/php.ini , I still see the edits I made prior to the reboot, but for some reasons, it is not reading my changes.

I am on a VPS and I opt to use the Lighttpd as the http web server, XCache has been enabled for the entire VPS. I do see XCache in phpinfo so it’s definitely enabled. I followed exactly what it said in http://wiki.dreamhost.com/XCache when making changes to the php.ini but alas, nothing is working. I still can’t get the xcache.size to change.

What else do I need to try? Thanks in advanced, guys and gals.


#2

Wow!! I submitted a Support ticket the same time as I posted this topic. I got a response within 30 minutes!! And it completely solved my problem. Thank you so much Samuel!

Here’s the solution:
First, make a php file with phpinfo(); and then point your browser to the page and check the field for “Scan this dir for additional .ini files” Create a php.ini file in that folder. Copy all the xcache settings to that file. Save and exit. Now just have to kill all the php5.cgi processes by issuing the killall php5.cgi command in SSH. PHP will start up again with the new updates.

Dreamhost support is still top notch in my eyes. This proves it beyond shadow of doubt. You just have to be concise and explain the situation thoroughly when submitting your tickets and include any relevant URL and screenshots. :slight_smile: