LaTeX not installed after ubuntu upgrade on strathclyde


#1

Anybody else trying to use LaTeX on strathclyde after the Ubuntu upgrade, just to find it wasn’t installed? I emailed dreamhost support about it, and am hoping to get some other interested users to chime in about that. LaTeX had been installed on strathclyde running Debian linux, so I was hoping the same packages would be available after the Ubuntu upgrade. And there’s a standard Ubuntu LaTeX package, so dreamhost can just apt-get it.

Meanwhile, any other problems anybody else is having on strathclyde after the Ubuntu upgrade? It might be useful to collect them all here so dreamhost can address them all at one fell swoop, rather than reading numerous individual emails all about the same problems.

Thanks,
John Forkosh john@forkosh.com


#2

I was thinking to myself, what sort of crazy newb would be using LaTeX on a web server? Then I remembered http://www.forkosh.com/mathtex.cgi?\frac1%7B\sqrt%7Ba%5E2+b%5E2%7D%7D. Yeah, actually that’s a good use for it.

If all else fails, you could install it local to your user with the live installer.


#3

Although if that’s what you’re doing, MathJax may be a better solution.


#4

I’m surprised you ever >>heard<< of mathtex at all, much less >>remembered<< it. :slight_smile:

Anyway, problem solved by installing texlive locally, using the install-tl-unx.tar.gz scripts from
https://www.tug.org/texlive/acquire-netinstall.html
That just installs over the net, which is pretty quick, ~70mins, from a dreamhost shell. And it “just worked” immediately. So the mathtex public web service is back up and running. But texlive takes 3GB (would be 4GB, but I omitted all the foreign language stuff). And strathclyde’s /home is a 4TB disk with ~1.5TB free, so that one app takes ~1/500-th of the available space. I wish they’d install it under /usr/local/ once and for all, where it belongs, but support@dreamhost didn’t seem interested in doing that.
[hr]

Yeah, nowadays there are several better solutions. But I wrote and gpl’ed mimetex back in 2002, and mathtex a few years later, at which time they were pretty much the only solutions. And lots of people who started using it back then are apparently finding it good enough, so that the trouble to change isn’t worth the effort.


#5

I’ve only heard of it because of a discussion we had some time ago about someone hacking your forgotten message boards and changing all of the permissions.

I would bet < 0.0001% of DH users would make use of LaTeX on a web server, so I don’t think there’s a strong case for putting forth the effort. I used to run Arch Linux off of a 4GB memory card and I managed to install a basic LaTeX distribution without eating up too much space. IIRC, it was much less than 1GB, probably around 200 or so for the basics and a few bells and whistles. I think with the live installer, you have to go with the minimal scheme + anything you absolutely need to keep it small. Otherwise, it’s LaTeX and the kitchen sink.


#6

Okay, now I’m surprised you remembered that “hacking your forgotten message boards” incident, which must have been ~5years ago (and you even remembered how to use the public web service).

Yeah, I suppose there are few online latex users, though installing it under /usr/local/ would put it on the /dev/sda disk mounted as /, rather than on the separate /dev/sdb disk mounted as /home. Anyway, I see that your suggested “live installer” at http://www.tug.org/texlive/doc/install-tl.html is indeed somewhat different than the https://www.tug.org/texlive/acquire-netinstall.html which I happened to google and use. But your live install page also says, “The default is scheme-full, to install everything,…”, so both default procedures probably include your “kitchen sink”. But I now recall there were several “schemes” I could have chosen when running the install script. So I probably could have done a better (less disk use) job. But I was in kind of a rush at the time, in order to get the web service running again, and apparently didn’t think about it enough before I acted. I’ll keep in mind the possibility of re-installing when time permits. Thanks for pointing that out.


#7

Off-topic, but I couldn’t resist changing my avatar to “one-up” yours.
But you can one-up yourself by looking at the following url

http://www.forkosh.com/gifgraph.cgi?100&50&s(x+t)+.5*s(2.*x+3.*t)$C\mbox{\bf~bobocat}&x=0.0;x<6.283;x+=0.05&t=0.0;t<6.283;t+=0.05

which reproduces the same animation changed to “bobocat”. The long ?query_string isn’t entirely displayed above. It’s…
100&50&s(x+t)+.5*s(2.*x+3.*t)$C\mbox{\bf~bobocat}&x=0.0;x<6.283;x+=0.05&t=0.0;t<6.283;t+=0.05
Besides the obvious bobocat change, the other stuff is explained at http://www.forkosh.com/gifsave89.html#gifgraph except for that uppercase C after the $. That C vertically centers your text, rather than default bottom placement. So you can animate any expression you like, as long as bc can evaluate it.

This is slightly not off-topic, to the extent that mimetex (not mathtex, but close enough) is used by gifgraph to pixelize your bobocat (or any latex math expression) text. And I have it down (somewhat way down) on my to-do list to add functionally similar code to mathtex so that it can also be used for that purpose by other apps.


#8

I completely overlooked your reply. That’s an interesting idea! The sytax looks a bit like TikZ, vaguely.


#9

+1 to this idea.