LAG - No doubt about it!

wordpress

#1

During the autumn I have been developing my personal WP theme, using Dreamweaver.
There have been no problems at all.

However for the last week or so, I have been experiencing STRANGE DELAYS IN UPDATES to pages that I have worked on.
From a technical perspective (I used to be a developer) I don’t know how this is even possible.

In the Wordpress forums, there are Dreamhost users complaining about this too. I thought they were crazy at first, but now it is happening to me as well.

I am developing against the live site. If I save a php , css or html change, I should see the difference immediately upon refreshing the web page.

This no longer happens Sometimes it is over 10 minutes until the change is reflected. Needless to say it is impossible to do any development in this situation.

Have you experienced anything similar?
I am logging a call with Dreamhost and I will post the response back here when I hear from them.


#2

No, I haven’t seen anything like that. Any changes I upload are reflected immediately on my sites.

Is it possible that this is a browser caching issue? Have you upgraded or changed browsers recently?

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )


#3

Hi and thanks for responding. Caching was the first thing I checked, and no, it’s off altogether in all my browsers actually.

Could there be some caching on the server side?

Here is what happens right now:

I change a font colour (just an example). I save the file, I refresh and NO CHANGE!

I go away for 5 minutes, come back, refresh and I see the change!

What on earth could be causing such behaviour?


#4

It’s possible of-course, but I have yet to see any sign of it here.

I do recall running into a similar problem a few years ago, before I began hosting at DreamHost, and the cause of that turned out to be my ISP running a transparent proxy which was caching pages.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )


#5

Do you have the wp-cache plugin enabled? If so, turn it off and see what happens.

I also wonder if it’s possible that your ISP is caching the site. As a test, you can log into your Dreamhost server via SSH or Telnet and do a wget to see if the change took immediate effect.

-Scott


#6

You are right, the WP Cache feature was ON.

I am sure it was off before, but I upgraded to WP 2.0.5 and this messed up all sorts of other things on the site, so very likely this as well.

(Be warned about that - it took ages to sort out! )

OK, Unless you hear back from me on this post, disabling WP Cache solved the problem… :slight_smile: Thanks!


#7

Good catch Scott, I completely forgot about wp-cache. :blush:

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )