Keep getting holding page despite setup looking correct


#1

Hi, I’m a bit puzzled way a domain which I’ve set up in the dreamhost control panel which is showing the correct DNS settings, and is pointing to the correct user/dir where the site files are, is consistently showing the holding page. This isn’t a cache issue, as I’ve cleared cache and have tried accessing the site using proxy browsers too, with the same result. It can’t be a propagation issue either, as the DNS records are showing the correct dreamhost nameservers etc for the last few days. I have other sites setup exactly the same way and comparing them side by side I can’t see any difference.

Is there anything I could be missing that would be causing this? I’ve changed the directory the domain points to a couple of times, just to see if that made any difference, but no.

Thanks for any help


#2

What shows up for http://www.whatsmydns.net/ ?


#3

I get the expected dreamhost DNS results:

A: 66.33.220.107
ns3.dreamhost.com.
ns2.dreamhost.com.
ns1.dreamhost.com.


#4

You’re getting our holding page, I presume? If you want to share (or PM me) your URL, I can take a look :slight_smile:


#5

Thanks - I’ve sent you an email with the URL (don’t have PM privileges it seems yet)


#6

That;s okay :slight_smile: I took a look and you just didn’t upload any files for that domain. When I look at the home folder for it, it’s empty.


#7

The files are there though - I have pointed that domain to this directory, /home/myusername/domain.co.uk - it should be reading the files from here, no? All the site files are in that diretory


#8

I looked in these (I have no idea why there are three) :
/home/myusername/domain.co.uk
/home/myusername/domain
/home/myusername/www.domain.co.uk

There are no files other than our quickstart ones. You have panel pointing to the /home/myusername/domain.co.uk one, so that is correct, but there’s just nothing there.


#9

This is very strange - I am connected via FTP and /home/myusername/domain.co.uk contains all the site files. The other two were just tests by me. Ownership and permissions of the files look fine. Any idea what could be happening here?

Thanks again for looking into this.


#10

The only thing I can think is you’re logged in as the wrong user?

In your FTP app, go ‘up’ a folder to /home/myusername/

Do you see the three different versions of your domain that I do? (There are 26 folders and 5 hidden files in that folder)


#11

how many index files do you have in the directory?


#12

I am logged in to FTP and control panel as stegra**, the root FTP folder for that account shows 22 folders and 7 files. I only see one of those folders related to this domain (mydomain.co.uk), the other two were deleted yesterday. In the control panel, the domain shows as Fully Hosted / User: stegra**. I’ve refreshed file list, logged in and back out of FTP, but same result. It does seem like it’s looking for the files under the wrong user account, but nothing in the control panel suggests this is the case.
[hr]

Just one, an index.html file. No index.php or .htm or any others.


#13

I have tried deleted the domain and recreated from scratch, ensuring I am logged in as the correct user. Still have the same issue, this is very puzzling.

Although, I did notice that when creating the domain, the usual dreamhost nameservers were outlined - the domain is already resolving to these nameservers, but the IP beside ns1.dreamhost.com is 66.33.220.106, whereas what I have my A record pointing to is 66.33.220.107 - could this be the issue?


#14

No, that part sounds normal. ns1.dreamhost.com is one of our core name servers; it supposed to be different from your web server.


#15

Okay. NOW we’ve gone into crazy-land, cause I still see those folders.

I made a ‘forum-hi.txt’ file in /home/username/

Can you see that?


#16

Right, so when I was logged into the FTP account yesterday and seeing different folders from you, it was on islamabad.dreamhost. However, when I tried to login via FTP just now, I got an authentication error and couldn’t get in at all. When I was looking at the FTP user credentials in the control panel, i noticed “montgomery” as the machine, not islamabad. Changing the FTP host to montgomery now gets me in, and I can see exactly what you see.

So, problem solved I guess - BUT, can anyone explain how this might have happened? I have been using the islamabad host/machine to manage all the sites under this account and have never had a problem till now. Is there any reason why this might have happened? I’m not very used to Dreamhost so I’m a bit baffled!

Thanks to all for their help on this thread, much appreciated.


#17

It looks like you were moved to our new datacenter in Virginia. I thought that they actually moved, and not duplicated, btu … well yeah that’s weird o.O

You should be ftping into ftp.domain.co.uk though, which would prevent that from happening ever again :slight_smile: