Joomla upload file size limit modification

apps

#1

Greetings!
This is my first post here… So, I come with a question.

On my website there is Joomla running with ZoomGalery. I would like to let my visitors to upload large files, like videos. Now the file limit is about 8 Mbytes, what is very small, of course, for any kinf of films.

I wrote to DreamHost, and -very quickly, indeed!- I got this answer:
"
No problem! We actually allow users to run their own custom PHP
installations within their home directory. You can do this by following
our step-by-step wiki article here:
http://wiki.dreamhost.com/index.php/Installing_PHP4

Doing this, you can enable libraries and php_flags that you need for your
php scripts.
"

Well, what I read there, is a bit too complex for me.

So, I come here for help.

Can you, please, assist me in making this modification?

Thanks,

Greetings,

Tamas


#2

There is actually a much simpler way to increase the max_upload_filesize by which you can modify and use your own php.ini file.

While not as versatile or powerful as a complete custom PHP install, this should meet your needs very well. Good Luck!

–rlparker


#3

Thanks a lot, rlparker!

I believe you, that this is simpler…
And it seems shorter, as well.
:slight_smile:

So, look at me as a beginner, please. (Or, as a photographer,… what I am…)

Where am I supposed to issue these commands?
What do I need to be able to do so?

Up to now I was using webftp of DreamHost or chrome://fireftp/content/fireftp.xul.

THANKS,

Tamas


#4

Welcome to DH fellow photographer. To make use of that wiki article you’ll need to connect to your server with SSH. A common windows program is Putty. If you carefully follow the custom php.ini instructions and don’t skip a step you’ll do just fine. If you don’t understand what do, take a break and ask for specific help in the forum.

Hope this helps.

–Matttail
art.googlies.net - personal website


#5

Hi Tamas,

First you should activate your user to use SSH.

I try to give a step-by-step how to set user as Shell user :

  1. Login to your web panel.
  2. Goto check on your domain which user is active on that domain (under column Web Hosting). Let’s say its user is “User1”.
  3. After that… go to manage user and check on “User1” (Under user column) and check on type column… is it a “shell” or “ftp” ?
  4. If it is “ftp”, you should change it to “shell”, so you click edit button under Actions column.
  5. Change it User Account Type: to “Shell Account”. Klik Save Changes button.

After that step, you are ready to connect to your server using SSH client. There are so many application of this type. I supposed you are under Windows… so you can use putty . Just run it after you download it. It will ask for your hostname => enter your domain name. Choose “SSH” protocol. And then click Open button.

It will shortly prompt you a login screen, provide username as you set from web panel (my example is “User1”). And after that provide your password. If all things are correct… you will login to your server. And from there you can configure your php as suggested by Custom PHP.ini wiki page.

Hope it helps. :slight_smile:

Dino

Get YOUR $97 off on yearly plan with [color=#CC0000]YOUGET97 [/color] promo code. Sign Up NOW


#6

Hello Dino!
yes, Yes, YES, YEEEES!
I could follow the steps! THANKS A LOT!
I went through all the steps… and I am just testing the upload with a bigger file.
By the way, I gave up Windows, and I run on Ubuntu. (It is not always the simplest… and I just LOVE it! The feeling is different! Relaxed, friendly and taking-giving!)

Some comments:

And after I went through the Wiki, as suggested.

THANKS for all of U!

The next question (may I?) :
How and where can I test if the new limit I had set up is taken into consideration by the system?

Freindly smiling greetings,

Tamas


#7

Create and upload a file called (say) info.php containing the following line…

<?php phpinfo(); ?>

Browsing to this file will show you lots of information about the current PHP installation, including the current settings for ‘upload_max_filesize’

Mark


Web Hosting Reviews | DreamHost Promo Code


#8

Thanks, Matttail!
I went through the steps… and I am just evaluating the result. :slight_smile:
(In the meantime I visited your site, as well… I posted a comment there.)

Greetings,

Tamas


#9

Thanks, Mark!

I am amaized, how nicely and quickly people help me here!
I really like it, thanks for ALL.

Yes, I did it… and it really gives me all the details… God, how many they are!

The upload still does not work… I gues it is now limited by the time. What do you think?

Directive Local Value Master Value
max_execution_time 30 30
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 90M 90M
open_basedir no value no value
output_buffering 4096 4096
output_handler no value no value
post_max_size 370M 370M
precision 14 14

When I upload, as a visitor… I do not see any error message, just it says, after a while… you are not authorized …

Should I still modfiy any other parameter? (Now I “know” how to do it… I hope… :-))

Thanks and greetings,

Tamas


#10

No problems Tamas, I am glad I could be of some assistance. :slight_smile:

Unfortunately, I do not have a great deal of experience with Joomla or ZoomGallery, so I can’t really offer any help.

You can try increasing max_execution_time, to see if that fixes the problem, no harm in trying I guess.

Perhaps someone more experienced with Joomla/ZoomGallery will be able to help more.

Good luck.

Mark


Web Hosting Reviews | DreamHost Promo Code


#11

Again… Thanks, Mark!
:slight_smile:

I keep on trying… :slight_smile:

Tamas


#12

NP, glad to be helful :slight_smile:

Btw, I just know there is putty on Ubuntu :stuck_out_tongue:

Thanks also for the info, will explore it as I use Ubuntu as well as Windows :wink:

Dino

Get YOUR $97 off on yearly plan with [color=#CC0000]YOUGET97 [/color] promo code. Sign Up NOW