Joomla upgrade

apps

#1

Yesterday we received a message regarding the upgrade of Joomla by Dreamhost. It was installed a long time ago by someone else and is not being used. Problem is now our site is not viewable.
This shows instead of the site:
PLEASE REMEMBER TO COMPLETELY
REMOVE THE INSTALLATION DIRECTORY.
You will not be able to proceed beyond this point until the installation directory has been removed. This is a security feature of Joomla!.
Click here when the directory has been removed.
Joomla! is free software released under the GNU/GPL v2.0 License.

No matter how many times the permissions are changed on the files & folders in the Installation folder - cannot delete or rename or move them.

How can it just go back the way it was?


#2

I’m having the same issue. I just changed to auto upgrade and it installed 1.5.25 but the new domain folder is root root 644 as are most of the files and folders inside thus I can’t delete the installation folder.

Thanks for any help,
David


#3

My issue was resolved by Edgar C. Apparently the install’s permissions got stuck on root during the upgrade. ??


#4

Sounds about right. Guess I have to submit a support ticket.


#5

I’m having this problem as well. After the automatic upgrade of Joomla by Dreamhost, can’t delete the installation directory in FileZilla no matter what I tried to do (rename, change permission, go up one directory and change all permission within…nothing works). This is pretty frustrating.


#6

I have the same problem with this today. How do I turn off “auto-update”? I do not want my sites to be updated automatically. I ended up just going back to the old file and using it. It works fine. But I want to delete the one that was installed today.


#7

I am having the same issue. Is there any resolution.
[hr]

To turn off auto-update: Go to the web Panel. On the top left is your tool box. Click “One-Click Installes”. Then click "Manage Installed Applications. Select your domain. Then under Upgrade action, click edit. Select "no action.
[hr]

To turn off auto-update: Go to the web Panel. On the top left is your tool box. Click “One-Click Installes”. Then click "Manage Installed Applications. Select your domain. Then under Upgrade action, click edit. Select "no action.


#8

It’s great that you could go back to the old file. I can’t even replace the new directory with my old directory. No permission.
[hr]

Yes, I did that to turn off the auto update as well. The “Manage Installed Applications” link is kind of hard to see (it kind of blends in with the page and doesn’t stand out). I can’t believe auto-update was on by default (I can’t remember selecting this when I install). Now my site is down and stuck at the “delete your installation directory warning”.


#9

Yes, I did that to turn off the auto update as well. The “Manage Installed Applications” link is kind of hard to see (it kind of blends in with the page and doesn’t stand out). I can’t believe auto-update was on by default (I can’t remember selecting this when I install). Now my site is down and stuck at the “delete your installation directory warning”.
[/quote]

Yes, Mine too. If they doen’t fix this soon I’m pulling all my sites off dreamhost. This can not happen. I am losing money.


#10

Same problem here. However, I would like to keep auto update on.

Do I need to submit a support ticket every time the auto update does its thing?

Has anyone found a solution other than submitting a help ticket?


#11

I submit a support ticket yesterday in the afternoon (about 18 hours ago) and my site is still on the “delete your installation directory” page!


#12

I had to submit a support ticket. They resolved the issue with in 2 hours. That was good. I’m back in business.


#13

Lucky you. My ticket was submitted 20 hours ago, but I still haven’t heard back. I’m sending another one.

I switched to Dreamhost earlier this year because I heard good reviews, but this is actually very disappointing.


#14

20hs and nobody from dreamhost said, just one "WORKING"
I want to know ETA to resolve this mess.
Im tired to pick up the phone, and say anything for my clients.

AdWords - Paused
Sales - Paused
New contacts -same

The first auto-update - "Was an Epic Fail"
Please SOLUTION - ETA


#15

I finally got a response after submitting another support ticket after 20 hours of downtime.

“There was an apparent bug with the recent one-click installer and Joomla. I have made note of this with our debug team and have fixed the issues for your domain. I have repaired the permissions and deleted the installation folder.”

I have turned off automatic update (Honestly why would anyone want it to be on by default?? An update can break your site!) so hopefully this will never happen again.


#16

We’re working on this right now, which you probably assumed.

Our devs were manually correcting the issue with permissions, but we’re pushing an update within the last hour that should correct this for you.

We’re really sorry about this, and we’re looking into exactly why it happened to prevent it in the future.


#17

Thanks. I appreciate the update. May I also suggest that auto-update be defaulted to “off” for future one click installs (or at least add a check box as an option)? When I did my install, it wasn’t shown anywhere that my site would be auto updated with a new version of Joomla, which to me seem really dangerous as that can break my plug-ins etc.


#18

Thank you!
Waiting for news.


#19

I’ll pass that on to the engineers.

If you go to your one-click install page - https://panel.dreamhost.com/index.cgi?tree=goodies.installer& - and click on ‘Manage installed Applications’, you can expand the items and see if auto-upgrade is turned on. It’s a little obscure, indeed, and we’ve been working on ways to make that both more obvious and intuitive.

Keep in mind, with Joomla (and a lot of similar products), not upgrading promptly can leave you vulnerable to security breaches. It’s encouraged in the Open Source community that hosts upgrade people to protect not only themselves, but everyone else on their servers. This, of course, makes it way too easy to argue both sides of the issue :confused: Do we make the ‘This will auto-upgrade!’ alert big so people see it, or do we not because they may turn it off without understanding the ramifications. There’s no one perfect answer, alas!

The fix was still running yesterday when I logged off, but it should be done today. If you’re still having the problem, update your ticket with us and ask if they can have it run manually for your site.


#20

I installed a new Joomla instance on a subdirectory, and of course it’s being auto updated today. However, when I go back to “Manage installed Applications” today and tried to turn auto upgrade off, I couldn’t. I really need to disable this for the future. Please advice. Thank you.