Joomla suddenly non-functional

apps

#1

I used DH’s one-click install for Joomla to create the site at www.clarioncounty.info, then I started adding content and add-ons. Yesterday, I visited my site, and everything looked fine – as it has for months.

This morning, I tried to check a specific page directly and got this error:

Parse error: syntax error, unexpected T_LNUMBER in … index.php at line 88

I couldn’t find a problem at first glance, and I don’t have time at the moment to debug. So, I’ve got the site redirected elsewhere temporarily.

I don’t understand what could suddenly make it hose up, though.

I checked the file dates and permissions, and nothing had changed.

Any assistance will be appreciated, since I’m slightly above novice with Joomla and complete novice with PHP.


#2

I just check it and get redirected to http://pa-roots.com/~clarion/. And it is not Joomla.

Do you install any 3rd party components/modules ?

Dino
Get YOUR $97 off on yearly plan with [color=#CC0000]YOUGET97 [/color] promo code. Sign Up NOW


#3

Because it is a high-traffic site that can’t be down, my backup plan is to redirect to the PA-Roots.com URL. The original site is a Joomla site that suddenly gave that error message, and I couldn’t find anything to help me resolve it on Joomla message boards.


#4

[quote]I tried to check a specific page directly and got this error:

Parse error: syntax error, unexpected T_LNUMBER in … index.php at line 88

I couldn’t find a problem at first glance, and I don’t have time at the moment to debug. So, I’ve got the site redirected elsewhere temporarily.[/quote]
That makes it really difficult for us to help you, as we can’t see the problem site at all.

I’m also confused as to what you mean “check a specific page directly”. Can you see the Joomla! site at all? Does the problem only occur on a specific page (menu item), or on all pages?

That error is a pretty generic parse error that often can be something as simple as an encoding problem with a snippet of code, but without the ability to do any forensics on it, I am only guessing.

Whether you “have the time” or not, debugging has to be done if you hope to identify the problem. Have there been any changes to your server (different/newer PHP version, etc.)? Can you identify a point in time when the site first “broke” (review of your error logs)?

I really don’t know what else to suggest until you are more clear about what is happening, and you can make the site available for testing. YOU however, can do quite a lot from the shell and by reviewing your logs. :wink:

–rlparker


#5

Hi – thanks for taking the time to respond. This past weekend was the deadline for submitting my final project in a grad school course, plus I was the coordinator of our annual family reunion with people coming from all over the place. So, I really didn’t have time to deal with the issue of site debugging.

And, as I wrote in another reply, this is a genealogy/history site that gets most of its traffic on weekends. So, I had to resort to my backup plan (redirecting) to another domain.

I was hoping this was an error someone else had seen and resolved. Your description of it as “common” makes me curious as to why I couldn’t find help on the Joomla message boards.

I’m not sure which logs you are describing. I understand the word “shell,” but I’m not familiar with using it to solve this type of problem.

I don’t know if the server configuration has changed. The FTP instructions for all my user accounts point to a server named yoda, and none of the other sites have this error.

Everything changed within a few hours. I completed the Gallery one-click update I’d forgotten about for some time in all the uproar of course assignments and planning for the family event. It went just fine, and I even got confirmation via an e-mail from a site visitor who had viewed some photos. Later that day, I got a message from another site visitor who said he got a Norton AV warning that one of my site’s pages was attempting to transfer a flavor of the Downloader virus to his system. In the past, I’ve received one or two similar messages from users. I and others (including Mac and Linux users) have been unable to replicate their problems. When I went to check the new guy’s message, I saw the Joomla error.

I couldn’t get anything to load. So, I FTP’d and checked files. No date stamps or permissions looked amiss. I manually edited Joomla’s config file to set the site to “off-line” in order to provide an apology to site visitors, but that did not work – I still got the error.

Again, I appreciate your attempt to help, especially since I’m kinda familiar with what I’m doing, but I’m nowhere near the comfort level I should be to solve this type of problem on my own.


#6

Well, I haven’t done much of anything yet except commiserate with you, but I’m willing to try. Some of the information you just provided helps us get started.

It is not particularly surprising that the Joomla! boards don’t have much about that error, as it is not particularly a Joomla! error as much as it is a PHP error, and there are several potential cause for it. We can come back to that later, after we do a little more research to help narrow down where to look. :wink:

The first place to start (since you can see no obvious changes in the dates/name of your files) is to review your error logs to see where the problem started surfacing. These are located in the /home/yourusername/logs/yourdomainname/http directory (which is above you domainname.tld directory), which you can reach via ssh in the shell or via ftp or sftp. Lof for and download/view your error logs for around the time(s) the problem was first encountered to see what apache logged as the cause of the error.

I understand, but there are a few other things you can check:

  1. manually inspect the contents of your index.php file and the index.php file for your chosen template, and look for any added “spammish” links - depending upon when this all happened your account may have been compromised (though this is not likely, you should check).

  2. Since all you data is in the database, you might be able to “resurrect” you Joomla! installation from the .snapshot automagic backup directories if you can find a snapshot that worked before the error manifested itself.

  3. It would also help me if you can get any more complete error message than the one you posted in you roriginal thread (“Parse error: syntax error, unexpected T_LNUMBER in … index.php at line 88”); was there any data omitted where the ellipses are shown? (I’m looking for which index.php the error was found in (joomla! has more than one, and I need more of the path than was provided).

Let’s not worry just yet about what Norton AV may have reported (God, I Hate that program!), let’s get to the bottom of your error condition first. :wink:

–rlparker