Joomla PHP register_globals setting

apps

#1

hello iam trying to install joomla and in the installation page it show that my php register_globals setting is “on” wherein it should be “off.” How can i make the setting to “off.” can someone guide me step by step to change the settings? thanks. iam new here.


#2

The easiest way of doing it is to log into the control panel and edit your hosting to use PHP5 instead of PHP4. PHP5 has register_globals set to off by default.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#3

thanks but after converting it to php5 i have a new error,
PHP magic_quotes_gpc setting is OFF instead of ON

what should i do with this? thaks again.


#4

That’s not a “error” it’s just a “warning” and actually is not a particularly useful or valid warning at that. :wink:

The only real reason you would want that setting to be “on” is to compensate to some degree for poor coding practices or to facilitate a plugin that requires its.

The core Joomla! installation doesn’t care about that setting, and there is no advantage to having it on for Joomla! itself or for well coded plugins. There has been considerable “discussion” over this “warning” on the Joomla! forums, and I believe that, on DreamHost, you are really better off with it set to “off”.

My advice is to ignore it. :wink:

–rlparker


#5

Hi, check out this blog post:

http://www.copesflavio.com/en/blog/cms/joomla/joomla-php-register-globals-on-or-off


#6

thanks for the help.
you guys are great! :slight_smile: