Joomla! Links Messed Up


#1

Hi. I have a small, simple Joomla! 1.5.2 website that has been running on DH for about 2 months. I just got back from being out of the country for 2 weeks, and the site is no longer working correctly. (Site is www.groundswellnw.org).

Here are the main problems:

  1. Internal links from menus are broken. For example, the “people” menu choice should go to URL “www.groundswellnw.org/index.php/people.html” (since I have SEF URL’s enabled). Instead, it goes to “http://www.groundswellnw.org/index.php/index.php/index.php/people.html”, so it is adding 2 extra “index.php/” to the URL.
  2. The default Template is not being used to format any pages other than the home page.
  3. My Banners are not displaying.

To repeat, this was all working great 2 weeks ago. There was a small amount of front-end editing done, but that shouldn’t mess up the menu items. Also, the menu items look good in the back end.

Any help about where to start troubleshooting this will be greatly appreciated. I’m pretty comfortable with Joomla! but am new to web stuff in general, especially Apache, PHP, MySQL, .htaccess, etc. Thanks a bunch! Mark


#2

This is a known issue with Joomla! 1.5.x and later versions of PHP5, and there is a lot of discussion about it on the Joomla! forums. Last time I checked they had not yet determined what the source of the problem is, or how to best address it (that may have changed by now).

The “short version” of all of that is that the “built in” SEF functionality is broken at present under PHP-CGI running PHP v 5.2.6, which is now what is being run on all DreamHost servers. This PHP upgrade was necessary for security reasons, and happened within the last 10 days on all DreamHost servers, which explains why you are seeing this.

For now, two methods of dealing with this that I know work are:

  1. Disable the “core” SEF Url usage in the Global Configuration screen of the back end. This is what I recommend anyway, as there is really nothing at all “Search Engine Friendly” about those Urls the standard Joomla! urls - Google and other search engines have not had any problem reading or indexing dynamically created PHP pages for quite some time now, and there is no “SEF” advantage to be gained by rewriting those urls.

  2. Disable the “core” SEF Url usage in the Global Configuration screen of the back end, and use the apache re-write rule version with .htaccess instead.

Either of these will get your links working again.

–rlparker
–DreamHost Tech Support


#3

It sounds like something’s messed up in a base path. Are you using their .htaccess file?

-Scott


#4

Scott, the problem does not exist if using the Joomla! supplied .htaccess file. It only manifests itself when using the new 1.5.x included “core” SEF routines. I suspect that it might be related to the elimination of the “livesite” path variable that was part of the 1.0.x series (where you could clearly specify the path) and the way the routines interact with PHP-CGI environment variables (though I have not thoroughly investigated this past finding a workaround for now).

–rlparker
–DreamHost Tech Support


#5

Hi. Thanks very much for the information. In the global configuration I changed the settings for Search Engine Friendly URLs and Add Suffix to URL’s to off. I also went into Extensions/Plug-in Manager and disabled the “System - SEF” plugin. Is that what you suggested? I initially thought that this fixed the URL problem. The URL’s looked correct when I went in. However, now (10 minutes later), the URL problem is still there. (I swear it was fixed for a few minutes.)

I also have a different problem which may or may not be new. When I first went to the site, it appeared to work correctly. However, when I continued to browse the site and pull up the same pages, they now are missing content. At this point I can’t get any of the pages to show the correct banner graphic or the correct content.

I may have had this problem before the PHP upgrade. I was looking at the site 2 weeks ago and had a similar problem. However, at that time, there seemed to be some DH issues with bad servers, etc. So I hoped that my problem was due to the server issue.

However, it is still not working correctly. I downloaded the database and files to my localhost and it works perfectly.

At this point, I still have the original problem (although now with SEF’s turned off and disabled). I also still have the inconsistent missing content problem.

Any other suggestions will be greatly appreciated. Thanks. Mark


#6

I saw the same thing on your site with a semi-good first load, then subsequent loads hang up. Right now, my Firefox is getting hung up on Paypal. And now it just gets hung up on the Banner image, which is experiencing the multiple index.php entries.

What’s interesting is that if I click on a broken link, and then fix it in my address bar, the site works pretty well.

By the way, I see you have the Events Calendar plugin. Which one is that, and are you running it in Legacy mode? I tried the 2.0.0 RC4, but kept getting an error message.

-Scott


#7

Not entirely, but close. What I was suggesting was simply the first step that you did, which was to disable the SEF in the global configuration. I don’t think disabling the “System SEF” plugin is necessary, as turning it off with the Global Configuration setting should have kept it from being used even if the plugin was left enabled.

Well, if there was a problem before, this won’t have resolved that problem, and it will still have to be dealt with. :wink:

I understand, but that can be very misleading - there are likely significant differences between your local system and our Debian based PHP-CGI v5.2.6 environments. This is one of the reasons I always develop on a “staging” site that is actually running on DreamHost servers when working with PHP based applications.

Mark, the only thing at this point that comes immediately to mind is the possibility of caching messing you up (The Joomla! cache setting, your own browser cache, etc.). I’d carefully check all of that and make sure I had all Joomla! caching turned off and a completely cleared computer/browser cache before proceeding - part, or all, of what you have been seeing could well be related to that.

–rlparker
–DreamHost Tech Support


#8

Hi. Thanks for the information. I’m using the JEvents in legacy mode. It works pretty well. The default colors were terrible (although I’m no color expert). But it works well for us. Mark


#9

Thanks! I had the Cache Time set to 15 minutes. I changed the Cache to “No” and now the site works perfectly.

So now I have 2 questions:

  1. Should I just leave the Cache set to No?
  2. On the SEF URL’s, I am not concerned about search engines. I had this setting turned on to get more “human friendly” URL’s. I think, if I understand you correctly, I can get “human friendly” URL’s using apache rewrite. Is this correct?

Thanks again for your help! Mark


#10

Good deal! Yeah, having Joomla! caching turned on makes it really hard to see what is really happening when you are “tuning” stuff. :wink:

I don’t think so, once you have the site setup and running correctly! Caching is much easier on the server and helps your page load considerably faster. I’d just make sure to turn it off when I’m working on stuff so you can actually see your changes.

Yes, that’s correct. Remember that there is a price to pay for that, however - the rewriting of urls takes time and server resources. Frankly, I feel that those “prettified” urls are not worth the resource expenditure. I mean, who “types in” a “deep link” anyway these days. I understand that you may feel differently about that. :wink:

Using the apache rewrite rules in the .htaccess file (or one of the “SEF” url plugins that are around) will prettifiy the urls for you.

–rlparker
–DreamHost Tech Support


#11

Thanks again. Maybe I’m missing something. I still can’t get it to work correctly with the Joomla! Cache enabled. I get the same behavior (missing content on subsequent page loads). I tried deleting temporary internet files in IE. Is there something else I need to do? Mark


#12

There is a Clean Cache menu item in the Admin screen under Tools.

-Scott


#13

Thanks! That’s what I was missing. It’s now working with the cache. Mark


#14

I spoke too soon. Here is what I have tried (twice).

  1. Turn off caching.
  2. Go to Tools/Clean Cache. Select all files and press Delete.
  3. Turn on caching (15 minutes).

When I do this, the site appears to work correctly for a short time. However, if I go back to the site after a few minutes, it behaves as before (missing content and incorrect URL’s).

So, the site works perfectly with cache turned off but not with cache turned on. Is there something else I need to do? Is 15 minutes a reasonable setting?

Thanks again for your help. Mark


#15

From further reading in the Joomla Forums, it seems that you may be able to “fix” this problem by manually adding the "livesite"
variable I mentioned earlier to your configuration.php file.

To do this, first check to see if the var is defined at all. If it is, you will see this line:

var $live_site = ‘’;

which you should change to this:

var $live_site = ‘http://domain.com’;

Where “domain.com” is your domain name/url where the Joomla! installation is installed. Make sure to include any subdirectory name that may apply if your Joomla! installation resides in a subdirectory.

If that var $live_site = ‘’; line is not in your configuration file, just add it as above:

var $live_site = ‘http://domain.com’;

in the file with all the other variables that are defined in the class JConfig

–rlparker
–DreamHost Tech Support


#16

Thank you very much. I had just found this same suggestion from a Joomla! forum and have implemented it. I set the $live_site = ‘http://www.groundswellnw.org’ and this fixes both of my problems. I can now have SEF URL’s enabled and use the cache and my site appears to work perfectly.

Thanks again for your great support. Mark Dexter


#17

THANK YOU parker !!!
YOu saved my a$$ … I had exactly the same issue and disabling the SEF i got everything working like a charm. Thank you Thank you Thank you !!!