Joomla installation problem

apps

#1

I installed on my site. Everything seemed to go fine until the “installation” removal step.

keeptherubbersidedown.com goes to http://keeptherubbersidedown.com/installation/index.php

But I can’t find an “installation” files or folders at my top level or top level/keeptherubbersidedown.com

I’m not a newbie, but I’m not much beyond it. I’ve looked with two different SFTP programs and no installation. I tried SSH and nothing even issued
rm -rf installation/
at both levels just in case.

One thing I did wrong was I had two folders (releases and shared) in my keeptherubbersidedown.com which I read later might not be a good idea. I could delete them and start over, but I don’t want to start madly deleting things. Those folders are from Rails experiments. I’m probably not up to getting Rails going, so went back to Joomla.

Thanks


#2

Well, it’s there. One option is just to rename it and add some numbers after “installation.” It’s not at the top level, but it’ll be inside your keeptherubbersidedown.com folder.

Try WebFTP from the panel for Domains -> Manage Domains. That’ll put you in the right place.

-Scott


#3

Only see the same two folders that I see using my FTP program (and I checked before posting to make sure the “installation” hadn’t showed up).

It appears you might be part of DH, so I pass the following. And if you’re not I’ve noted it if not reported it. I initially tried clicking on the folder icon and got:

Not Found
The requested URL /keeptherubbersidedown.com was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

The above message when I clicked on keeptherubbersidedown.com from WebFTP. URL:https://webftp.dreamhost.com/keeptherubbersidedown.com

Then I noticed the spot to enter the url and I put in root /keeptherubbersidedown.com
and I got into the folder, but alas as I reported no installation.

Thanks for responding.

BTW I had to use FireFox. Safari couldn’t log into WebFTP. I’m on a Mac.


#4

I’m not staff; just a customer. I’m not sure what you mean by “And if you’re not I’ve noted it if not reported it.” It sounds accusatory.

What do you see when you first FTP to your site? There should be a logs directory, maybe a Maildir, and your keeptherubbersidedown.com directory. I’ve only used Safari when logging into WebFTP, so it’s strange it doesn’t work for you.

How about trying standard FTP, like command line from Terminal on the Mac? Personally, I use Transmit.

If you’ve submitted a Support ticket, hopefully they can straighten this out.

-Scott


#5

Sorry, I didn’t mean to be accusatory. I was apologizing for not reporting what I saw as a bug with Safari.

I admit it’s a very awkward sentence. Too many "it"s.

When I first FTP using Transmit, I see Maildir and other a few other folders that I created (trying out different sites etc.).

In my keeptherubbersidedown.com folder I see two other folders and nothing else, from an attempt to use Rails (which I had some use for, but that project has gone away, so I figured Joomla was more my speed.).

In other words the same thing I see with WebFTP.

Time to put in a support ticket or empty the keeptherubbersidedown.com and start over. The FAQ mentioned starting with an empty folder. Of course, I didn’t see that caveat until after I already did it.

Thanks for responding. And thanks for asking for clarification on my poor wording rather than going off or giving up.


#6

This could indicate you’ve installed J! into a different folder.

Go back and check where it’s actually installed.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#7

To add to sXi’s comments, you’d go to the Panel under Domains -> Manage Domains and click Edit for that domain. It’ll show you the FTP user, plus the installation directory.

I’ve reread your earlier post and I’m not clear where the bulk of Joomla is installed. Are the Joomla files actually in your keeptherubbersidedown.com folder? There should be the index.php, modules/ plugins/ templates/ and other stuff. Is that stuff where you think it should be?

-Scott


#8

I looked in every folder. But obviously it’s somewhere.


#9

I just completed a joomla instalation and I am having the same issue. All i see is Maildi and the log directories and see a few other files. i can only go in through web FTP on a second account I set up. the first one i am unable to get to the right ftp server. the second one prepopulated the correct information and was easy to log in. I also am needing some help and am getting very frustrated.


#10

I’m pretty sure that a One-Click won’t install into a folder that’s not empty. I just can’t remember if it flags it right away, or emails you that the install failed.

I keep thinking that the answer lies in your Fully Hosted settings. If you’d like a second set of eyes, PM me with a screenshot of the Fully Hosted Edit window of Domains -> Manage Domains.

-Scott


#11

Maybe you chose an Easy Install and it glitched out?

Take a gander in [color=#0000CC]Goodies > One-Click Installs > Upgrade[/color]

You can delete the installation there and try again (using Advanced One-Click).

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#12

That thought flashed through my mind and then I double-checked and found that Joomla isn’t available in Easy Mode.

-Scott


#13

Fixed, sort of. Thanks everyone. Of course the “installation” was there, but it was in a subdomain and two levels deep. I found it after deleting and reinstalling (using the DH Installer page), and still having problems. I hit the back one from the page on my site saying I needed to delete “installation” and the URL changed to a subdomain which told me where too look.

Scott, your comment on finding the files reinforces this. That’s the folder that everything is in.

Now I need to figure out why I’m getting sent to the subdomain instead. I’ll have to comb through my control panel settings.

Although I’m tempted to wipe everything clean and start completely over. But I’m not even sure how to do that. Probably start by deleting everything I can find in the control panel and then seeing what’s left via ftp.

Thanks all.