Joomla installation problem



I am new to DH and I am trying to install a joomla webiste on my DH account. I was wondering if anyone knows how to turn register global “off”. Do I need to use php.ini or modify .htaccess to make it work?

Thank you very much.



If you go into the Control Panel and edit your domain, you can switch to using PHP5 (which has register_globals disabled by default). Otherwise, you can put the following in your .htaccess file:php_flag register_globals 0--------
Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


Thanks for your info. I am not sure if Joomla is in php5 so do you know if it is going to affect the proper operation of Joomla? If I were to change the .htaccess file, do I just change the .htaccess in the Joomla folder or the .htaccess file in my domain’s web directory(home/username/public_html)? I cannot seem to find any .htaccess in the root.

Thank you.


Joomla! works fine with PHP5, but support for MySQL 5 is said to be patchy.

It should be in the web root folder, as far as I know. If you don’t have an .htaccess file in your web root (domain folder), simply create one.

Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


Change the one the “joomla” folder (for the scenario you described).

.htaccess effects all directories below its location in the directory tree. If the Joomla installation is at your “public_html” level, that is where it the appropriate .htaccess should go, but if it is in its own directory (home/username/.dataglob/pulbic_html/joomlasite) then the .htaccess should go in the “joomlasite” directory.

BTW - I don’t believe the register_globals_off issue is a dealbreaker. The “red” warning at the installation screen is just that, a warning, and joomla will run fine in that condition. Joomla 1.08 and up even has an alternate way to “simulate” glboals being off to enhance security when running on a host with globals set “on”. There is a lot more info on that at the joomla forums and in the docs :slight_smile: I have been running numerous Joomla sites on Dreamhost using the “stock” PHP4 as CGI configuration (which has globals “on”) without issue.



I ran into problems when trying to get Joomla to run on PHP5 and reverted to PHP4. I don’t recall the specifics at this point, but don’t currently see a need to update. I was able to get Joomla to run on MySQL v5.0.16 with just a simple change. I wrote about it on my site, which is running on Dreamhost with the configuration I just mentioned. It also runs fine on my home machine using Apache on Windows.

The link is included simply so you can evaluate the performance of the site with MySQL5. I have also pasted a description of the fix below. Link:

From my site:
I started using MySQL 5, and was unable to save any new data in Joomla. For a long time I thought this was a problem with my installation. but eventually I found that it was an incompatibility with MySQL 5. The upcoming version of Joomla addresses the compatibility issues, but I didn’t want to wait that long. It turns out that disabling strict SQL mode in the MySQL configuration solved my problem. Simply open your “my.ini” file within the MySQL installation directory, and look for the text “sql-mode”

Original Entry:

Set the SQL mode to strict


New Entry:

Set the SQL mode to strict


BC Tech
Team Shocker


Joomla will work fine under the standard Dreamhost environment. The difference in that setting doesn’t seem to make a difference.


In my case, I had very specific issues when using Joomla with the original settings. The initial install and setup worked fine, but the whole reason I chose this CMS was for it’s extensibility, and to get involved creating my own mambots, modules, and components.

My problems arose when I attempted using the admin panel to install additional functionality. For me the option of making this configuration change was a no-brainer when compared to recoding all the module files and rearchiving them before they would install.

Your mileage may vary, so I am just trying to offer some insight into my own personal experience.

BC Tech
Team Shocker