Joomla: failed to open stream

apps

#1

I’m a real PHP newbie, and I’m getting the following errors when I install a new theme in Joomla. Any ideas on how to fix it?

Warning: main(templates/fv_newsportal/config.php): failed to open stream: No such file or directory in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 75

Warning: main(templates/fv_newsportal/config.php): failed to open stream: No such file or directory in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 75

Warning: main(): Failed opening ‘templates/fv_newsportal/config.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 75

Warning: main(templates/fv_newsportal/php/dynamic.inc.php): failed to open stream: No such file or directory in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 76

Warning: main(templates/fv_newsportal/php/dynamic.inc.php): failed to open stream: No such file or directory in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 76

Warning: main(): Failed opening ‘templates/fv_newsportal/php/dynamic.inc.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/.flute/alexcg/shanghainn.com/cms/templates/funky-visions/index.php on line 76

Really appreciate any help anyone can give. Thanks!


#2

I am also facing the same problem, Did you find the solution to it. If yes please help me. Help sought from all,

regards


#3

That’s pretty straightforward; the error message is telling you that two files (templates/fv_newsportal/config.php and templates/fv_newsportal/php/dynamic.inc.php) called by the index.php files of your template can’t be opened.

This is usually the result of the template developer misconfiguring the “zip” file containing the template. Somethimes they have stored the files in the wrong directory, other times they may have omitted them. or it could be something as simple as a typo in the spelling of the filenames. Either way, the fix is to either correct lines 75 and 76 of your template’s index.php file to point to the correct location of those files, or move those files to the location indicated on line 75 and 76.

Short answer: your template package is broken. You might search about and see if an “updated” or “corrected” version of your template has been released; sometimes that is easier than fixing it yourself if you are very new to php.

–rlparker


#4

could this have to do w/ the fact that when JOOMLA is installed via oneclick install there is a hint from the DH installer to remove the .blah part in the home path.
I have done exactly that (in my case it was .divet) but have now several components that are looking for some files in a home path still including the .divet.

looking for a solution right now cause the default homepath in the cofinguration part is correct without the .divet, which means that there must be another location with the ‘incorrect’ path.

lars behrenroth