Joomla Extention Manager


#1

Hi all and thank you for reading this post.

I have Joomla 1.5.2 installed and I just can’t seem to install any components from the Extention Manager while on dreamhost. The only way I’ve been successful is to install them on my local machine then upload the site back to dh.

I’ve been to the Joomla forums and have tried just about every suggestion there to no avail (chmodded, check write status, play with ftp host).

If I try to install the zip package, I get:
JFTP::store: Bad response
Warning! - Failed to move file

If I try to install from directory, I get this error:
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
Component Install: Failed to create directory: “/home/.ablate/me/test.domain.org/components/com_rsgallery2”

I know I’m doing something wrong but just can’t figure it out. Can someone point me in the right direction. I really don’t care for my current solution :wink:

Thank you


#2

That is certainly not normal, as I have many several Joomla! 1.5.x installations running on various DreamHost shared servers, and all is working well on each of them. It might help us to understand how things got “messed up” if you told us whether you installed Joomla! yourself, or whether you used the DreamHost “one-click” installer.

Hopefully your attempts to get things working have not made things worse; the “stock” Joomla! 1.5.2 should work properly on DreamHost without any modification of the settings it has when shipped. The first thing I suggest is that your return your installation to it’s “just out of the box” state (as far as permissions, and an “empty” FTP layer are concerned). I say this because any changes to the global configuration that yo may have made are likely to only make it harder to identify the cause of your problem.

[quote]If I try to install the zip package, I get:
JFTP::store: Bad response
Warning! - Failed to move file

If I try to install from directory, I get this error:
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
Component Install: Failed to create directory: “/home/.ablate/me/test.domain.org/components/com_rsgallery2”

I know I’m doing something wrong but just can’t figure it out. Can someone point me in the right direction. I really don’t care for my current solution ;)[/quote]
Two things are indicated by the error messages that you are receiving:

  1. Joomla is attempting to use the FTP layer to install the extensions, and …

  2. The FTP layer is either not installed correctly, or there are some other permissions related issues/problems.

It is important that you understand Joomla! does not need to utilize the FTP layer at all when installed on a DreamHost shared server. If you do include setup information for an FTP layer, Joomla! will try to use it, and if it is not setup properly, or there are permission issues between the FTP user for the FTP layer and the machine user that is Joomla! is running under (your user), you will have problems.

Even if you have the FTP layer setup “correctly”, unless you use your own FTP user when setting it up, and use a directory within you own machine user’s space, you will have permissions issues due to the way security is setup on DreamHost and the linux filesystem’s permission management. There is more information about all of this in a previous post where this is discussed.

If you review the information in that post, you will see that you should not use the FTP layer on DreamHost; it is only needed for some systems that do not have the “robust” PHP-CGI environment that DreamHost offers (running under suEXEC).

If you eliminate the use of the FTP layer completely from your Joomla! installation (remove the settings from the global configuration), clear you browser’s cache, log out of Joomla!, and log back in again (sessions concern here), you should be able to upload extensions from within the Joomla! back end without further difficulty.

–rlparker


#3

Thank you for taking the time to help me. My ignorance led to a great deal of confusion but I was successful in installing the component now.

Fortunately, I make backup copies of things I go change so I have my original configuration. The ftp_enable was already set to ‘0’ but I went ahead and removed all the other information in the ftp section as well, that is =’’;. Seems to have done the trick.

I did use the one-click installer in advanced mode. It was then I was having problems so started fiddling with things until I found out Blingy was in trouble and stopped everything.

So, I don’t know where or when my head got so turned around but your explanation about ftp and permissions helped a lot.

Pab

(by the way, just in case dh pop their heads into these forums, Good job guys! I can’t even guess how much of a pita that was/is! And I can actually work on my site now, yaa)


#4

Good Deal! You are welcome,and I’m glad you are able to install your components/extensions now. :slight_smile:

–rlparker


#5

I was having a similar problem with my Joomla 1.5.3 install – couldn’t install any components – but wasn’t getting any sort of error message … no message at all, actually.

I tried the above suggestion and deleted the following ftp-related lines from my configuration.php file:

var $ftp_host = ‘127.0.0.1’;
var $ftp_port = ‘21’;
var $ftp_user = ‘’;
var $ftp_pass = ‘’;
var $ftp_root = ‘’;
var $ftp_enable = ‘0’;

And it worked! Thank you!!